aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/ase
diff options
context:
space:
mode:
authorTino Reichardt <milky-lede@mcmilk.de>2017-02-26 21:26:08 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-06-03 21:14:07 +0200
commit9b321bc60de3ee6f41fa5bcb6593e07399782714 (patch)
treee1ec66c7f3b1fdc18ad8b0748ce128af846b4017 /target/linux/lantiq/ase
parent1039e41deadd2d4f23b7b6ccdad28fbcc65cfdb4 (diff)
downloadupstream-9b321bc60de3ee6f41fa5bcb6593e07399782714.tar.gz
upstream-9b321bc60de3ee6f41fa5bcb6593e07399782714.tar.bz2
upstream-9b321bc60de3ee6f41fa5bcb6593e07399782714.zip
lantiq: add Amazon-SE subtarget
Re-Add support for the Amazon-SE subtarget on Lantiq. Signed-off-by: Tino Reichardt <milky-lede@mcmilk.de>
Diffstat (limited to 'target/linux/lantiq/ase')
-rw-r--r--target/linux/lantiq/ase/config-default26
-rw-r--r--target/linux/lantiq/ase/profiles/00-default.mk9
-rw-r--r--target/linux/lantiq/ase/target.mk20
3 files changed, 55 insertions, 0 deletions
diff --git a/target/linux/lantiq/ase/config-default b/target/linux/lantiq/ase/config-default
new file mode 100644
index 0000000000..b6cd4f3910
--- /dev/null
+++ b/target/linux/lantiq/ase/config-default
@@ -0,0 +1,26 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_CC_OPTIMIZE_FOR_SIZE=y
+CONFIG_CPU_MIPS32_R1=y
+# CONFIG_CPU_MIPS32_R2 is not set
+CONFIG_CPU_MIPSR1=y
+CONFIG_CRC16=y
+CONFIG_CRYPTO_DEFLATE=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_FIRMWARE_MEMMAP=y
+CONFIG_GPIO_GENERIC=y
+CONFIG_GPIO_GENERIC_PLATFORM=y
+CONFIG_HAVE_IRQ_EXIT_ON_IRQ_STACK=y
+# CONFIG_ISDN is not set
+# CONFIG_LBDAF is not set
+CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+CONFIG_MIPS_FPU_EMULATOR=y
+# CONFIG_PSB6970_PHY is not set
+# CONFIG_RTL8366_SMI is not set
+CONFIG_SOC_AMAZON_SE=y
+# CONFIG_SOC_XWAY is not set
+# CONFIG_SPI is not set
+CONFIG_USB_SUPPORT=y
+# CONFIG_WIRELESS is not set
+# CONFIG_WLAN is not set
+CONFIG_ZLIB_DEFLATE=y
+CONFIG_ZLIB_INFLATE=y
diff --git a/target/linux/lantiq/ase/profiles/00-default.mk b/target/linux/lantiq/ase/profiles/00-default.mk
new file mode 100644
index 0000000000..26bc8b502b
--- /dev/null
+++ b/target/linux/lantiq/ase/profiles/00-default.mk
@@ -0,0 +1,9 @@
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/lantiq/ase/target.mk b/target/linux/lantiq/ase/target.mk
new file mode 100644
index 0000000000..5f6c03b38e
--- /dev/null
+++ b/target/linux/lantiq/ase/target.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2016 LEDE Project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+ARCH:=mips
+SUBTARGET:=ase
+BOARDNAME:=Amazon-SE
+FEATURES:=squashfs atm mips16 small_flash
+CPU_TYPE:=mips32
+
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug \
+ kmod-ltq-adsl-ase kmod-ltq-adsl-ase-mei \
+ kmod-ltq-adsl-ase-fw-b kmod-ltq-atm-ase \
+ ltq-adsl-app ppp-mod-pppoe
+
+define Target/Description
+ Lantiq Amazon-SE Boards
+endef