aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2010-12-12 22:57:16 +0000
committerJohn Crispin <blogic@openwrt.org>2010-12-12 22:57:16 +0000
commit3a8cab4295251305a2b8fba4f5ba3b9340915957 (patch)
tree24f859f8849a0d5180c1bef85c758ce70aa43c80 /target/linux/lantiq/Makefile
parent30ce14b5fcdfbc1d739af351ab01e8d3e287f174 (diff)
downloadupstream-3a8cab4295251305a2b8fba4f5ba3b9340915957.tar.gz
upstream-3a8cab4295251305a2b8fba4f5ba3b9340915957.tar.bz2
upstream-3a8cab4295251305a2b8fba4f5ba3b9340915957.zip
[lantiq] adds new lantiq kernel. once the codebase is fully tested and know to be working on all the devices previously supported by ifxmips, we will drop ifxmips support.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24526 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/Makefile')
-rw-r--r--target/linux/lantiq/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
new file mode 100644
index 0000000000..5afe5662da
--- /dev/null
+++ b/target/linux/lantiq/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=lantiq
+BOARDNAME:=Lantiq GPON/XWAY
+FEATURES:=squashfs jffs2 atm
+SUBTARGETS:=xway
+
+LINUX_VERSION:=2.6.35.9
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for Lantiq SoC
+endef
+
+$(eval $(call BuildTarget))