aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-09-03 01:03:22 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-09-03 01:03:22 +0000
commita70e0d066579a06c33b8504cb92badaf22dce1a3 (patch)
tree3e832707071c695622e35ca7a6a8ab4f24e648ec /target/linux/kirkwood
parent3fe1d8503c103a699ceb41e2eeec1c197bb9e977 (diff)
downloadupstream-a70e0d066579a06c33b8504cb92badaf22dce1a3.tar.gz
upstream-a70e0d066579a06c33b8504cb92badaf22dce1a3.tar.bz2
upstream-a70e0d066579a06c33b8504cb92badaf22dce1a3.zip
Add kernel package for the mv_cesa crypto module
SVN-Revision: 22877
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/modules.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/kirkwood/modules.mk b/target/linux/kirkwood/modules.mk
new file mode 100644
index 0000000000..ed7fe883a5
--- /dev/null
+++ b/target/linux/kirkwood/modules.mk
@@ -0,0 +1,11 @@
+
+define KernelPackage/crypto-mv_cesa
+ TITLE:=Marvell crypto engine
+ KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+ FILES:=$(LINUX_DIR)/crypto/mv_cesa.ko
+ AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+ SUBMENU:=Cryptographic API modules
+ DEPENDS:=kmod-crypto-core
+endef
+
+$(eval $(call KernelPackage,crypto-mv_cesa))