aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-07-27 12:30:41 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-20 14:19:39 +0200
commita14f5bb4bd263c21e103f13279d0c2ff03e48fe5 (patch)
tree18eecef0be1356f014d81b0427471ae18c8839c2 /target/linux/kirkwood
parentcc75344044e5c16cd4994d824db5779a5ac057c2 (diff)
downloadupstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.gz
upstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.bz2
upstream-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.zip
treewide: use wpad-basic-wolfssl as default
In order to support SAE/WPA3-Personal in default images. Replace almost all occurencies of wpad-basic and wpad-mini with wpad-basic-wolfssl for consistency. Keep out ar71xx from the list as it won't be in the next release and would only make backports harder. Build-tested (build-bot settings): ath79: generic, ramips: mt7620/mt76x8/rt305x, lantiq: xrx200/xway, sunxi: a53 Signed-off-by: Petr Štetiar <ynezz@true.cz> [rebase, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/image/Makefile4
-rw-r--r--target/linux/kirkwood/profiles/00-default.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index c6d1c335ca..89042d1726 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -38,7 +38,7 @@ define Device/checkpoint_l-50
DEVICE_VENDOR := Check Point
DEVICE_MODEL := L-50
DEVICE_PACKAGES := kmod-ath9k kmod-gpio-button-hotplug kmod-mvsdio \
- kmod-rtc-s35390a kmod-usb-ledtrig-usbport wpad-basic
+ kmod-rtc-s35390a kmod-usb-ledtrig-usbport wpad-basic-wolfssl
IMAGES := sysupgrade.bin
endef
TARGET_DEVICES += checkpoint_l-50
@@ -100,7 +100,7 @@ TARGET_DEVICES += iom_ix2-200
define Device/linksys
DEVICE_VENDOR := Linksys
- DEVICE_PACKAGES := kmod-mwl8k wpad-basic kmod-gpio-button-hotplug
+ DEVICE_PACKAGES := kmod-mwl8k wpad-basic-wolfssl kmod-gpio-button-hotplug
KERNEL_IN_UBI :=
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
diff --git a/target/linux/kirkwood/profiles/00-default.mk b/target/linux/kirkwood/profiles/00-default.mk
index bfc2154c48..4bad7d6681 100644
--- a/target/linux/kirkwood/profiles/00-default.mk
+++ b/target/linux/kirkwood/profiles/00-default.mk
@@ -7,7 +7,7 @@
define Profile/Default
NAME:=Default Profile
- PACKAGES:=kmod-mwl8k wpad-basic
+ PACKAGES:=kmod-mwl8k wpad-basic-wolfssl
PRIORITY:=1
endef