aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-05-03 21:52:21 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-14 21:16:20 +0200
commit987292b20a3d8f93ea259967b359becd4952c83a (patch)
tree71dde6d7168fe050efc92ede3d54a0c38cc9e58c /target/linux/kirkwood
parente53ec043bae15a643e7225d8e4194e6b7ed5e3e0 (diff)
downloadupstream-987292b20a3d8f93ea259967b359becd4952c83a.tar.gz
upstream-987292b20a3d8f93ea259967b359becd4952c83a.tar.bz2
upstream-987292b20a3d8f93ea259967b359becd4952c83a.zip
kirkwood: move ext4 support to modules
Ext4 support is built in kirkwood kernel. This patch moves ext4 support to modules and enables it for devices with SATA interface. Reviewed-by: Sungbo Eo <mans0n@gorani.run> Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> [rebase] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/config-5.42
-rw-r--r--target/linux/kirkwood/image/Makefile18
2 files changed, 9 insertions, 11 deletions
diff --git a/target/linux/kirkwood/config-5.4 b/target/linux/kirkwood/config-5.4
index a04bce9635..f4af47bd0a 100644
--- a/target/linux/kirkwood/config-5.4
+++ b/target/linux/kirkwood/config-5.4
@@ -120,7 +120,6 @@ CONFIG_DTC=y
# CONFIG_EARLY_PRINTK is not set
CONFIG_EDAC_ATOMIC_SCRUB=y
CONFIG_EDAC_SUPPORT=y
-CONFIG_EXT4_FS=y
CONFIG_FIXED_PHY=y
CONFIG_FIX_EARLYCON_MEM=y
CONFIG_FORCE_PCI=y
@@ -204,7 +203,6 @@ CONFIG_IRQCHIP=y
CONFIG_IRQ_DOMAIN=y
CONFIG_IRQ_FORCED_THREADING=y
CONFIG_IRQ_WORK=y
-CONFIG_JBD2=y
CONFIG_KIRKWOOD_CLK=y
CONFIG_KIRKWOOD_THERMAL=y
CONFIG_LEDS_GPIO=y
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 85bf0118ac..210afbe59f 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -51,7 +51,7 @@ define Device/cloudengines_pogoplugv4
DEVICE_VENDOR := Cloud Engines
DEVICE_MODEL := Pogoplug V4
DEVICE_DTS := kirkwood-pogoplug-series-4
- DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-mvsdio kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 kmod-mvsdio kmod-usb3
endef
TARGET_DEVICES += cloudengines_pogoplugv4
@@ -66,8 +66,8 @@ define Device/iom_ix2-200
DEVICE_VENDOR := Iomega
DEVICE_MODEL := StorCenter ix2-200
DEVICE_DTS := kirkwood-iomega_ix2_200
- DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-gpio-button-hotplug \
- kmod-hwmon-lm63
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 \
+ kmod-gpio-button-hotplug kmod-hwmon-lm63
PAGESIZE := 512
SUBPAGESIZE := 256
BLOCKSIZE := 16k
@@ -112,7 +112,7 @@ define Device/raidsonic_ib-nas62x0
DEVICE_VENDOR := RaidSonic
DEVICE_MODEL := ICY BOX IB-NAS62x0
BOARD_NAME := ib62x0
- DEVICE_PACKAGES := kmod-ata-marvell-sata
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4
endef
TARGET_DEVICES += raidsonic_ib-nas62x0
@@ -127,7 +127,7 @@ define Device/seagate_goflexnet
DEVICE_VENDOR := Seagate
DEVICE_MODEL := GoFlexNet
BOARD_NAME := goflexnet
- DEVICE_PACKAGES := kmod-ata-marvell-sata
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4
endef
TARGET_DEVICES += seagate_goflexnet
@@ -135,14 +135,14 @@ define Device/seagate_goflexhome
DEVICE_VENDOR := Seagate
DEVICE_MODEL := GoFlexHome
BOARD_NAME := goflexhome
- DEVICE_PACKAGES := kmod-ata-marvell-sata
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4
endef
TARGET_DEVICES += seagate_goflexhome
define Device/zyxel_nsa310b
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := NSA310b
- DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-r8169 \
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-r8169 kmod-fs-ext4 \
kmod-gpio-button-hotplug kmod-hwmon-lm85
BOARD_NAME := nsa310b
endef
@@ -152,8 +152,8 @@ define Device/zyxel_nsa325
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := NSA325
DEVICE_VARIANT := v1/v2
- DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-gpio-button-hotplug \
- kmod-rtc-pcf8563 kmod-usb3
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 \
+ kmod-gpio-button-hotplug kmod-rtc-pcf8563 kmod-usb3
BOARD_NAME := nsa325
endef
TARGET_DEVICES += zyxel_nsa325