aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-09-30 11:42:06 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2022-12-27 08:05:23 +0100
commit6be9e3e63685a11577f6650b51f45c72ef82180c (patch)
tree098c4a40a9ad80b72fa7c3879169d99c02c425c0 /target/linux/kirkwood
parentb1722a048ae920a24dfb898b7c97ebb6e1593e37 (diff)
downloadupstream-6be9e3e63685a11577f6650b51f45c72ef82180c.tar.gz
upstream-6be9e3e63685a11577f6650b51f45c72ef82180c.tar.bz2
upstream-6be9e3e63685a11577f6650b51f45c72ef82180c.zip
kernel: remove hack patch, move kirkwood specific kmods to target modules.mk
Tweaking the KCONFIG line of kmod-ata-marvell-sata makes the hack patch unnecessary Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry picked from commit 2e375e9b3148cfdb9b19494a25eebc2fa7b256a3)
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/modules.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/kirkwood/modules.mk b/target/linux/kirkwood/modules.mk
new file mode 100644
index 0000000000..1543098cd4
--- /dev/null
+++ b/target/linux/kirkwood/modules.mk
@@ -0,0 +1,30 @@
+define KernelPackage/ata-marvell-sata
+ TITLE:=Marvell Serial ATA support
+ DEPENDS:=@TARGET_kirkwood
+ KCONFIG:=CONFIG_SATA_MV CONFIG_SATA_PMP=y
+ FILES:=$(LINUX_DIR)/drivers/ata/sata_mv.ko
+ AUTOLOAD:=$(call AutoLoad,41,sata_mv,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-marvell-sata/description
+ SATA support for marvell chipsets
+endef
+
+$(eval $(call KernelPackage,ata-marvell-sata))
+
+define KernelPackage/mvsdio
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell MMC/SD/SDIO host driver
+ DEPENDS:=+kmod-mmc @TARGET_kirkwood
+ KCONFIG:= CONFIG_MMC_MVSDIO
+ FILES:= \
+ $(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
+ AUTOLOAD:=$(call AutoProbe,mvsdio,1)
+endef
+
+define KernelPackage/mvsdio/description
+ Kernel support for the Marvell SDIO host driver.
+endef
+
+$(eval $(call KernelPackage,mvsdio))