aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-11-10 23:55:10 +0000
committerLuka Perkov <luka@openwrt.org>2014-11-10 23:55:10 +0000
commit6c196e1ea77aff9f9dc7c716e3f3ce79037db18b (patch)
treeddf645f88ba2d530c06ee48228c9ac1083d98175 /target/linux/kirkwood/profiles
parentc0fd27ae720f08b264115b8cfbce414662a96c89 (diff)
downloadupstream-6c196e1ea77aff9f9dc7c716e3f3ce79037db18b.tar.gz
upstream-6c196e1ea77aff9f9dc7c716e3f3ce79037db18b.tar.bz2
upstream-6c196e1ea77aff9f9dc7c716e3f3ce79037db18b.zip
kirkwood: add support for Linksys EA3500
http://wiki.openwrt.org/toh/linksys/ea3500 Signed-off-by: Dan Walters <dan@walters.io> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43230 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/115-router.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/115-router.mk b/target/linux/kirkwood/profiles/115-router.mk
index 000aa7418f..ef7f228d2c 100644
--- a/target/linux/kirkwood/profiles/115-router.mk
+++ b/target/linux/kirkwood/profiles/115-router.mk
@@ -5,6 +5,22 @@
# See /LICENSE for more information.
#
+define Profile/EA3500
+ NAME:=Linksys EA3500
+ PACKAGES:= \
+ kmod-mwl8k kmod-usb2 kmod-usb-storage \
+ uboot-envtools
+endef
+
+define Profile/EA3500/Description
+ Package set compatible with Linksys EA3500 board.
+endef
+
+EA3500_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+EA3500_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,EA3500))
+
define Profile/EA4500
NAME:=Linksys EA4500
PACKAGES:= \