aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/patches-4.19/105-goflexhome.patch
diff options
context:
space:
mode:
authorPaul Wassi <p.wassi@gmx.at>2018-12-27 15:39:36 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-17 19:22:39 +0100
commitd42c9ce326aaf8eb0eeb0fd944eb5905cec4be4a (patch)
tree5df7fcb6164a7bb5ecdfdbd66178123e2e9deda7 /target/linux/kirkwood/patches-4.19/105-goflexhome.patch
parent66e875a07033cdcfd8c4a16940d4acfe63c60202 (diff)
downloadupstream-d42c9ce326aaf8eb0eeb0fd944eb5905cec4be4a.tar.gz
upstream-d42c9ce326aaf8eb0eeb0fd944eb5905cec4be4a.tar.bz2
upstream-d42c9ce326aaf8eb0eeb0fd944eb5905cec4be4a.zip
kirkwood: add kernel 4.19 support
Add patches for 4.19 Drop patch 200-disable-tso, as the packet corruption was fixed in kernel commit 3b89624ab54b9dc2d92fc08ce2670e5f19ad8ec8 Restructure the DTS for Marvell switch in 104-ea3500 and 105-ea4500 to fix DTC warning. Signed-off-by: Paul Wassi <p.wassi@gmx.at>
Diffstat (limited to 'target/linux/kirkwood/patches-4.19/105-goflexhome.patch')
-rw-r--r--target/linux/kirkwood/patches-4.19/105-goflexhome.patch130
1 files changed, 130 insertions, 0 deletions
diff --git a/target/linux/kirkwood/patches-4.19/105-goflexhome.patch b/target/linux/kirkwood/patches-4.19/105-goflexhome.patch
new file mode 100644
index 0000000000..9ac30b6d30
--- /dev/null
+++ b/target/linux/kirkwood/patches-4.19/105-goflexhome.patch
@@ -0,0 +1,130 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -256,6 +256,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
+ kirkwood-ds411.dtb \
+ kirkwood-ds411j.dtb \
+ kirkwood-ds411slim.dtb \
++ kirkwood-goflexhome.dtb \
+ kirkwood-goflexnet.dtb \
+ kirkwood-guruplug-server-plus.dtb \
+ kirkwood-ib62x0.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-goflexhome.dts
+@@ -0,0 +1,117 @@
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6281.dtsi"
++
++/ {
++ model = "Seagate GoFlex Home";
++ compatible = "seagate,goflexhome", "marvell,kirkwood-88f6281", "marvell,kirkwood";
++
++ memory@0 {
++ device_type = "memory";
++ reg = <0x00000000 0x8000000>;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200n8 earlyprintk root=/dev/sda1 rootdelay=10";
++ stdout-path = &uart0;
++ };
++
++ ocp@f1000000 {
++ pinctrl: pin-controller@10000 {
++ pmx_usb_power_enable: pmx-usb-power-enable {
++ marvell,pins = "mpp29";
++ marvell,function = "gpio";
++ };
++ pmx_led_white: pmx-led-white {
++ marvell,pins = "mpp40";
++ marvell,function = "gpio";
++ };
++ pmx_led_green: pmx-led_green {
++ marvell,pins = "mpp46";
++ marvell,function = "gpio";
++ };
++ pmx_led_orange: pmx-led-orange {
++ marvell,pins = "mpp47";
++ marvell,function = "gpio";
++ };
++ };
++ serial@12000 {
++ status = "ok";
++ };
++
++ sata@80000 {
++ status = "okay";
++ nr-ports = <2>;
++ };
++
++ };
++ gpio-leds {
++ compatible = "gpio-leds";
++
++ health {
++ label = "status:green:health";
++ gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
++ linux,default-trigger = "default-on";
++ };
++ fault {
++ label = "status:orange:fault";
++ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
++ };
++ misc {
++ label = "status:white:misc";
++ gpios = <&gpio1 8 GPIO_ACTIVE_LOW>;
++ linux,default-trigger = "disk-activity";
++ };
++ };
++ regulators {
++ compatible = "simple-bus";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = <&pmx_usb_power_enable>;
++ pinctrl-names = "default";
++
++ usb_power: regulator@1 {
++ compatible = "regulator-fixed";
++ reg = <1>;
++ regulator-name = "USB Power";
++ regulator-min-microvolt = <5000000>;
++ regulator-max-microvolt = <5000000>;
++ enable-active-high;
++ regulator-always-on;
++ regulator-boot-on;
++ gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
++ };
++ };
++};
++
++&nand {
++ chip-delay = <40>;
++ status = "okay";
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x0000000 0x100000>;
++ read-only;
++ };
++
++ partition@100000 {
++ label = "ubi";
++ reg = <0x100000 0x0ff00000>;
++ };
++};
++
++&mdio {
++ status = "okay";
++
++ ethphy0: ethernet-phy@0 {
++ reg = <0>;
++ };
++};
++
++&eth0 {
++ status = "okay";
++ ethernet0-port@0 {
++ phy-handle = <&ethphy0>;
++ };
++};