aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/patches-4.14/105-goflexhome.patch
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-02-24 21:06:04 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-27 12:38:21 +0100
commit16965a0f3f897ed48d9b8b7b53e0358c3a38ce6e (patch)
tree72178f2452e74e5d81545ed4190cea1fc94b394b /target/linux/kirkwood/patches-4.14/105-goflexhome.patch
parentebc090e420d1fc3ed30fc9f0331ee95422c2bace (diff)
downloadupstream-16965a0f3f897ed48d9b8b7b53e0358c3a38ce6e.tar.gz
upstream-16965a0f3f897ed48d9b8b7b53e0358c3a38ce6e.tar.bz2
upstream-16965a0f3f897ed48d9b8b7b53e0358c3a38ce6e.zip
kirkwood: convert DTS patches into plain DTS files
Move DTS files newly created by patch files to files directory. This will make these files much more maintainable. Patching the kernel Makefile is unnecessary, as the DTS files specified in DEVICE_DTS will be compiled by OpenWrt buildroot anyway. Signed-off-by: Sungbo Eo <mans0n@gorani.run> Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/kirkwood/patches-4.14/105-goflexhome.patch')
-rw-r--r--target/linux/kirkwood/patches-4.14/105-goflexhome.patch137
1 files changed, 0 insertions, 137 deletions
diff --git a/target/linux/kirkwood/patches-4.14/105-goflexhome.patch b/target/linux/kirkwood/patches-4.14/105-goflexhome.patch
deleted file mode 100644
index fcccbf7f39..0000000000
--- a/target/linux/kirkwood/patches-4.14/105-goflexhome.patch
+++ /dev/null
@@ -1,137 +0,0 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -237,6 +237,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
- kirkwood-ds411.dtb \
- kirkwood-ds411j.dtb \
- kirkwood-ds411slim.dtb \
-+ kirkwood-goflexhome.dtb \
- kirkwood-goflexnet.dtb \
- kirkwood-guruplug-server-plus.dtb \
- kirkwood-ib62x0.dtb \
---- /dev/null
-+++ b/arch/arm/boot/dts/kirkwood-goflexhome.dts
-@@ -0,0 +1,124 @@
-+/dts-v1/;
-+
-+#include "kirkwood.dtsi"
-+#include "kirkwood-6281.dtsi"
-+
-+/ {
-+ model = "Seagate GoFlex Home";
-+ compatible = "seagate,goflexhome", "marvell,kirkwood-88f6281", "marvell,kirkwood";
-+
-+ aliases {
-+ led-boot = &led_health;
-+ led-failsafe = &led_fault;
-+ led-running = &led_health;
-+ led-upgrade = &led_fault;
-+ };
-+
-+ memory {
-+ device_type = "memory";
-+ reg = <0x00000000 0x8000000>;
-+ };
-+
-+ chosen {
-+ bootargs = "console=ttyS0,115200n8 earlyprintk root=/dev/sda1 rootdelay=10";
-+ stdout-path = &uart0;
-+ };
-+
-+ ocp@f1000000 {
-+ pinctrl: pin-controller@10000 {
-+ pmx_usb_power_enable: pmx-usb-power-enable {
-+ marvell,pins = "mpp29";
-+ marvell,function = "gpio";
-+ };
-+ pmx_led_white: pmx-led-white {
-+ marvell,pins = "mpp40";
-+ marvell,function = "gpio";
-+ };
-+ pmx_led_green: pmx-led_green {
-+ marvell,pins = "mpp46";
-+ marvell,function = "gpio";
-+ };
-+ pmx_led_orange: pmx-led-orange {
-+ marvell,pins = "mpp47";
-+ marvell,function = "gpio";
-+ };
-+ };
-+ serial@12000 {
-+ status = "ok";
-+ };
-+
-+ sata@80000 {
-+ status = "okay";
-+ nr-ports = <2>;
-+ };
-+
-+ };
-+ gpio-leds {
-+ compatible = "gpio-leds";
-+
-+ led_health: health {
-+ label = "status:green:health";
-+ gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
-+ default-state = "on";
-+ };
-+ led_fault: fault {
-+ label = "status:orange:fault";
-+ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
-+ };
-+ misc {
-+ label = "status:white:misc";
-+ gpios = <&gpio1 8 GPIO_ACTIVE_LOW>;
-+ linux,default-trigger = "disk-activity";
-+ };
-+ };
-+ regulators {
-+ compatible = "simple-bus";
-+ #address-cells = <1>;
-+ #size-cells = <0>;
-+ pinctrl-0 = <&pmx_usb_power_enable>;
-+ pinctrl-names = "default";
-+
-+ usb_power: regulator@1 {
-+ compatible = "regulator-fixed";
-+ reg = <1>;
-+ regulator-name = "USB Power";
-+ regulator-min-microvolt = <5000000>;
-+ regulator-max-microvolt = <5000000>;
-+ enable-active-high;
-+ regulator-always-on;
-+ regulator-boot-on;
-+ gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
-+ };
-+ };
-+};
-+
-+&nand {
-+ chip-delay = <40>;
-+ status = "okay";
-+
-+ partition@0 {
-+ label = "u-boot";
-+ reg = <0x0000000 0x100000>;
-+ read-only;
-+ };
-+
-+ partition@100000 {
-+ label = "ubi";
-+ reg = <0x100000 0x0ff00000>;
-+ };
-+};
-+
-+&mdio {
-+ status = "okay";
-+
-+ ethphy0: ethernet-phy@0 {
-+ reg = <0>;
-+ };
-+};
-+
-+&eth0 {
-+ status = "okay";
-+ ethernet0-port@0 {
-+ phy-handle = <&ethphy0>;
-+ };
-+};