aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-04-20 10:06:36 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-28 16:49:31 +0200
commit4fd7e539e4f90128bdd7cb71c729a4b32f5de86e (patch)
tree74caf584970ce1d8c1b5c6604e2c228d3a97faea /target/linux/kirkwood/image
parent4b3b8ec81cd1965d0bd548fa31db491295b83354 (diff)
downloadupstream-4fd7e539e4f90128bdd7cb71c729a4b32f5de86e.tar.gz
upstream-4fd7e539e4f90128bdd7cb71c729a4b32f5de86e.tar.bz2
upstream-4fd7e539e4f90128bdd7cb71c729a4b32f5de86e.zip
kirkwood: switch from swconfig to dsa
This patch removes support for swconfig and switches to dsa driver. swconfig and switch drivers are removed. DSA driver is enabled and configuration is adjusted. In kirkwood only two devices have switches: Linksys EA3500 and EA4500. WAN MAC configuration in 02_network is required because otherwise WAN would have the same MAC address as lan interfaces. In swconfig solution the WAN address was assigned in u-Boot to eth1. Now, as eth1 is disabled and wan is part of the switch, we have to set it manually. Compile tested: EA3500, EA4500 Run tested: EA4500 Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> [minor commit title/message adjustments, remove swconfig package for devices] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 865122ae19..4ba9f9a1b2 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -82,7 +82,7 @@ TARGET_DEVICES += iom_ix2-200
define Device/linksys_audi
DEVICE_VENDOR := Linksys
DEVICE_MODEL := EA3500 (Audi)
- DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-basic kmod-gpio-button-hotplug
+ DEVICE_PACKAGES := kmod-mwl8k wpad-basic kmod-gpio-button-hotplug
PAGESIZE := 512
SUBPAGESIZE := 256
BLOCKSIZE := 16k
@@ -97,7 +97,7 @@ TARGET_DEVICES += linksys_audi
define Device/linksys_viper
DEVICE_VENDOR := Linksys
DEVICE_MODEL := E4200v2 / EA4500 (Viper)
- DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-basic kmod-gpio-button-hotplug
+ DEVICE_PACKAGES := kmod-mwl8k wpad-basic kmod-gpio-button-hotplug
KERNEL_SIZE := 2688k
KERNEL_IN_UBI :=
UBINIZE_OPTS := -E 5