aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-01-08 23:49:22 +0100
committerMathias Kresin <dev@kresin.me>2018-01-09 22:06:55 +0100
commit0674a99f7eb0c630b25eca774e3fe341d6c0efc8 (patch)
treee4531d269100322f0133d8119861bfc47e60efce /target/linux/kirkwood/image
parent0e94df65ca7f6a5c39421100c223c92889205b6f (diff)
downloadupstream-0674a99f7eb0c630b25eca774e3fe341d6c0efc8.tar.gz
upstream-0674a99f7eb0c630b25eca774e3fe341d6c0efc8.tar.bz2
upstream-0674a99f7eb0c630b25eca774e3fe341d6c0efc8.zip
kirkwood: sort occurrences of boardame alphabetically
This restores the alphabetical sort that was present before the renaming of boardname. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile118
1 files changed, 59 insertions, 59 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index f04c0323fb..39d93275f4 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -27,29 +27,40 @@ define Device/Default
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
endef
-define Device/seagate_dockstar
- DEVICE_DTS := kirkwood-dockstar
- DEVICE_TITLE := Seagate FreeAgent Dockstar
- BOARD_NAME := dockstar
- SUPPORTED_DEVICES += dockstar
+define Device/cisco_on100
+ DEVICE_TITLE := Cisco Systems ON100
+ DEVICE_DTS := kirkwood-on100
+ DEVICE_PACKAGES := kmod-i2c-mv64xxx
+ KERNEL_SIZE := 5376k
+ KERNEL_IN_UBI := 0
+ UBINIZE_OPTS := -E 5
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+ BOARD_NAME := on100
endef
-TARGET_DEVICES += seagate_dockstar
+TARGET_DEVICES += cisco_on100
-define Device/seagate_goflexnet
- DEVICE_TITLE := Seagate GoFlexNet
- DEVICE_DTS := kirkwood-goflexnet
- BOARD_NAME := goflexnet
- SUPPORTED_DEVICES += goflexnet
+define Device/cloudengines_pogoe02
+ DEVICE_TITLE := Cloud Engines Pogoplug E02
+ DEVICE_DTS := kirkwood-pogo_e02
+ BOARD_NAME := pogo_e02
+ SUPPORTED_DEVICES += pogo_e02
endef
-TARGET_DEVICES += seagate_goflexnet
+TARGET_DEVICES += cloudengines_pogoe02
-define Device/seagate_goflexhome
- DEVICE_TITLE := Seagate GoFlexHome
- DEVICE_DTS := kirkwood-goflexhome
- BOARD_NAME := goflexhome
- SUPPORTED_DEVICES += goflexhome
+define Device/cloudengines_pogoplugv4
+ DEVICE_TITLE := Cloud Engines Pogoplug V4
+ DEVICE_DTS := kirkwood-pogoplug-series-4
+ DEVICE_PACKAGES := kmod-usb3
endef
-TARGET_DEVICES += seagate_goflexhome
+TARGET_DEVICES += cloudengines_pogoplugv4
+
+define Device/iom_iconnect-1.1
+ DEVICE_TITLE := Iomega Iconnect
+ DEVICE_DTS := kirkwood-iconnect
+ BOARD_NAME := iconnect
+ SUPPORTED_DEVICES += iconnect
+endef
+TARGET_DEVICES += iom_iconnect-1.1
define Device/linksys_audi
DEVICE_TITLE := Linksys EA3500 (Audi)
@@ -77,13 +88,37 @@ define Device/linksys_viper
endef
TARGET_DEVICES += linksys_viper
-define Device/iom_iconnect-1.1
- DEVICE_TITLE := Iomega Iconnect
- DEVICE_DTS := kirkwood-iconnect
- BOARD_NAME := iconnect
- SUPPORTED_DEVICES += iconnect
+define Device/raidsonic_ib-nas62x0
+ DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
+ DEVICE_DTS := kirkwood-ib62x0
+ BOARD_NAME := ib62x0
+ SUPPORTED_DEVICES += ib62x0
endef
-TARGET_DEVICES += iom_iconnect-1.1
+TARGET_DEVICES += raidsonic_ib-nas62x0
+
+define Device/seagate_dockstar
+ DEVICE_DTS := kirkwood-dockstar
+ DEVICE_TITLE := Seagate FreeAgent Dockstar
+ BOARD_NAME := dockstar
+ SUPPORTED_DEVICES += dockstar
+endef
+TARGET_DEVICES += seagate_dockstar
+
+define Device/seagate_goflexnet
+ DEVICE_TITLE := Seagate GoFlexNet
+ DEVICE_DTS := kirkwood-goflexnet
+ BOARD_NAME := goflexnet
+ SUPPORTED_DEVICES += goflexnet
+endef
+TARGET_DEVICES += seagate_goflexnet
+
+define Device/seagate_goflexhome
+ DEVICE_TITLE := Seagate GoFlexHome
+ DEVICE_DTS := kirkwood-goflexhome
+ BOARD_NAME := goflexhome
+ SUPPORTED_DEVICES += goflexhome
+endef
+TARGET_DEVICES += seagate_goflexhome
define Device/zyxel_nsa310b
DEVICE_TITLE := ZyXEL NSA310b
@@ -101,39 +136,4 @@ define Device/zyxel_nsa325
endef
TARGET_DEVICES += zyxel_nsa325
-define Device/cisco_on100
- DEVICE_TITLE := Cisco Systems ON100
- DEVICE_DTS := kirkwood-on100
- DEVICE_PACKAGES := kmod-i2c-mv64xxx
- KERNEL_SIZE := 5376k
- KERNEL_IN_UBI := 0
- UBINIZE_OPTS := -E 5
- IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
- BOARD_NAME := on100
-endef
-TARGET_DEVICES += cisco_on100
-
-define Device/cloudengines_pogoe02
- DEVICE_TITLE := Cloud Engines Pogoplug E02
- DEVICE_DTS := kirkwood-pogo_e02
- BOARD_NAME := pogo_e02
- SUPPORTED_DEVICES += pogo_e02
-endef
-TARGET_DEVICES += cloudengines_pogoe02
-
-define Device/cloudengines_pogoplugv4
- DEVICE_TITLE := Cloud Engines Pogoplug V4
- DEVICE_DTS := kirkwood-pogoplug-series-4
- DEVICE_PACKAGES := kmod-usb3
-endef
-TARGET_DEVICES += cloudengines_pogoplugv4
-
-define Device/raidsonic_ib-nas62x0
- DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
- DEVICE_DTS := kirkwood-ib62x0
- BOARD_NAME := ib62x0
- SUPPORTED_DEVICES += ib62x0
-endef
-TARGET_DEVICES += raidsonic_ib-nas62x0
-
$(eval $(call BuildImage))