aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-13 00:36:01 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-31 15:03:43 +0200
commit65305cb44869774a7db10c517b871dce5ab46ccb (patch)
tree32d6daf0310d38c7be9b97d5caf5370f35d228c6 /target/linux/kirkwood/image/Makefile
parent217877d046414878126e5c8013162e3b7edc774c (diff)
downloadupstream-65305cb44869774a7db10c517b871dce5ab46ccb.tar.gz
upstream-65305cb44869774a7db10c517b871dce5ab46ccb.tar.bz2
upstream-65305cb44869774a7db10c517b871dce5ab46ccb.zip
kirkwood: use real model names for Linksys devices
This replaces the internal device names "Audi" and "Viper" with the real model names, which a user would look for. This makes the Linksys devices on this target consistent with the names recently changed for mvebu based on the same idea. As a consequence, the "viper" device definition is split into two separate definitions with the correct names for both real models. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/kirkwood/image/Makefile')
-rw-r--r--target/linux/kirkwood/image/Makefile47
1 files changed, 30 insertions, 17 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 6554fc2669..3a600da13c 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -96,34 +96,47 @@ define Device/iom_ix2-200
endef
TARGET_DEVICES += iom_ix2-200
-define Device/linksys_audi
- $(Device/dsa-migration)
+define Device/linksys
DEVICE_VENDOR := Linksys
- DEVICE_MODEL := EA3500 (Audi)
DEVICE_PACKAGES := kmod-mwl8k wpad-basic kmod-gpio-button-hotplug
+ KERNEL_IN_UBI :=
+ UBINIZE_OPTS := -E 5
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+endef
+
+define Device/linksys_e4200-v2
+ $(Device/linksys)
+ $(Device/dsa-migration)
+ DEVICE_MODEL := E4200
+ DEVICE_VARIANT := v2
+ DEVICE_DTS := kirkwood-e4200-v2
+ KERNEL_SIZE := 2688k
+ SUPPORTED_DEVICES += linksys,viper linksys-viper
+endef
+TARGET_DEVICES += linksys_e4200-v2
+
+define Device/linksys_ea3500
+ $(Device/linksys)
+ $(Device/dsa-migration)
+ DEVICE_MODEL := EA3500
+ DEVICE_DTS := kirkwood-ea3500
PAGESIZE := 512
SUBPAGESIZE := 256
BLOCKSIZE := 16k
KERNEL_SIZE := 2624k
- KERNEL_IN_UBI :=
- UBINIZE_OPTS := -E 5
- IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
- BOARD_NAME := linksys-audi
+ SUPPORTED_DEVICES += linksys,audi linksys-audi
endef
-TARGET_DEVICES += linksys_audi
+TARGET_DEVICES += linksys_ea3500
-define Device/linksys_viper
+define Device/linksys_ea4500
+ $(Device/linksys)
$(Device/dsa-migration)
- DEVICE_VENDOR := Linksys
- DEVICE_MODEL := E4200v2 / EA4500 (Viper)
- DEVICE_PACKAGES := kmod-mwl8k wpad-basic kmod-gpio-button-hotplug
+ DEVICE_MODEL := EA4500
+ DEVICE_DTS := kirkwood-ea4500
KERNEL_SIZE := 2688k
- KERNEL_IN_UBI :=
- UBINIZE_OPTS := -E 5
- IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
- BOARD_NAME := linksys-viper
+ SUPPORTED_DEVICES += linksys,viper linksys-viper
endef
-TARGET_DEVICES += linksys_viper
+TARGET_DEVICES += linksys_ea4500
define Device/raidsonic_ib-nas62x0
DEVICE_VENDOR := RaidSonic