aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/base-files/lib/ixp4xx.sh
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-17 22:03:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-17 22:03:46 +0000
commit96fa602499456e804b5ed721adecb8b7ac0a06ba (patch)
treea8ab3a477a2efa116283faaf032f8cfaa7894b04 /target/linux/ixp4xx/base-files/lib/ixp4xx.sh
parent879b7a7a9b1c99920a8a5c1f5329e060b564aca6 (diff)
downloadupstream-96fa602499456e804b5ed721adecb8b7ac0a06ba.tar.gz
upstream-96fa602499456e804b5ed721adecb8b7ac0a06ba.tar.bz2
upstream-96fa602499456e804b5ed721adecb8b7ac0a06ba.zip
ixp4xx: add sysupgrade support
Signed-off-by: Tim Harvey <tharvey@gateworks.com> target/linux/ixp4xx/base-files/lib/ixp4xx.sh | 25 ++ target/linux/ixp4xx/base-files/lib/upgrade/platform.sh | 156 +++++++++++++++++ target/linux/ixp4xx/image/Makefile | 11 + 3 files changed, 192 insertions(+) SVN-Revision: 33828
Diffstat (limited to 'target/linux/ixp4xx/base-files/lib/ixp4xx.sh')
-rw-r--r--target/linux/ixp4xx/base-files/lib/ixp4xx.sh25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/base-files/lib/ixp4xx.sh b/target/linux/ixp4xx/base-files/lib/ixp4xx.sh
new file mode 100644
index 0000000000..f7a6b76eda
--- /dev/null
+++ b/target/linux/ixp4xx/base-files/lib/ixp4xx.sh
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+
+ixp4xx_board_name() {
+ local machine
+ local name
+
+ machine=$(awk 'BEGIN{FS="[ \t]+:[ \t]"} /Hardware/ {print $2}' /proc/cpuinfo)
+
+ case "$machine" in
+ "Gateworks Cambria"*)
+ name="cambria"
+ ;;
+ "Gateworks Avila"*)
+ name="avila"
+ ;;
+ *)
+ name="generic";
+ ;;
+ esac
+
+ echo $name
+}