aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-12-23 08:10:35 +0000
committerRod Whitby <rod@whitby.id.au>2006-12-23 08:10:35 +0000
commitf3ad40579216431d84c49c5e009f988c3e65d33f (patch)
treec1bd5bfefcac7828e3fbd3e435d4bbbe94ab731d /target/linux/ixp4xx-2.6
parentaa80149e73e2ac9155d55fcd9cf9b7190e3377f2 (diff)
downloadupstream-f3ad40579216431d84c49c5e009f988c3e65d33f.tar.gz
upstream-f3ad40579216431d84c49c5e009f988c3e65d33f.tar.bz2
upstream-f3ad40579216431d84c49c5e009f988c3e65d33f.zip
Generate a flashable image for the NSLU2
SVN-Revision: 5893
Diffstat (limited to 'target/linux/ixp4xx-2.6')
-rw-r--r--target/linux/ixp4xx-2.6/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
index 79979ec78c..6142d09faf 100644
--- a/target/linux/ixp4xx-2.6/image/Makefile
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -29,6 +29,12 @@ endef
define Image/Build/jffs2-128k
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+ BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
+ -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
+ -r Ramdisk:1,Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+ -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+# -L $(BIN_DIR)/apex-nslu2-armeb.bin
+# -m $(BIN_DIR)/NPE-B
endef
$(eval $(call BuildImage))