aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-05 00:21:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-05 00:21:30 +0000
commit8621fbdb4e3d794b34c505364f979512b7339c51 (patch)
tree408bde99550660e5e199ca4a1f55fd7d10df05c9 /target/linux/ixp4xx-2.6/image
parent275ff405d8b923140d32b6ad702bb100673d6f8a (diff)
downloadupstream-8621fbdb4e3d794b34c505364f979512b7339c51.tar.gz
upstream-8621fbdb4e3d794b34c505364f979512b7339c51.tar.bz2
upstream-8621fbdb4e3d794b34c505364f979512b7339c51.zip
add squashfs support for ixp4xx
SVN-Revision: 6522
Diffstat (limited to 'target/linux/ixp4xx-2.6/image')
-rw-r--r--target/linux/ixp4xx-2.6/image/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
index bb33aff7f8..52cca6668a 100644
--- a/target/linux/ixp4xx-2.6/image/Makefile
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -37,17 +37,27 @@ define Image/Build
$(call Image/Build/$(1),$(1))
endef
+define Image/Build/slug
+ BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
+ -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
+ -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
+ -r Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+ -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+endef
+
define Image/Build/jffs2-64k
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
endef
define Image/Build/jffs2-128k
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
- BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
- -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
- -r Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
- -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+ $(call Image/Build/slug,$(1))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+ $(call Image/Build/slug,$(1))
endef
$(eval $(call BuildImage))