aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq807x
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-02-15 17:05:30 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-02-15 23:29:01 +0100
commit8c3bcc1989ac5fb596da86bfd82af6f8aafca1ab (patch)
tree49ed0c483e8807782d74ad84d2dc9969f21f7cae /target/linux/ipq807x
parent061e863baef89776ede9478384458c434ccbf434 (diff)
downloadupstream-8c3bcc1989ac5fb596da86bfd82af6f8aafca1ab.tar.gz
upstream-8c3bcc1989ac5fb596da86bfd82af6f8aafca1ab.tar.bz2
upstream-8c3bcc1989ac5fb596da86bfd82af6f8aafca1ab.zip
ipq807x: move AQR driver from built-in to kmod
ipq807x does not compile-in hwmon core, and this is leading to the hwmon code in AQR driver not being compiled due to IS_REACHABLE(CONFIG_HWMON) evaluating to false as hwmon is being built as a module. So, lets not compile-in Aquantia PHY driver so it can be included as kmod instead to have functioning hwmon. This allows using the thermal sensors in AQR-s as thermal zones for cooling devices like fans. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ipq807x')
-rw-r--r--target/linux/ipq807x/Makefile2
-rw-r--r--target/linux/ipq807x/config-5.151
2 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/ipq807x/Makefile b/target/linux/ipq807x/Makefile
index f753cb3f50..fdabf575d3 100644
--- a/target/linux/ipq807x/Makefile
+++ b/target/linux/ipq807x/Makefile
@@ -14,7 +14,7 @@ include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
kmod-usb3 kmod-usb-dwc3 kmod-usb-dwc3-qcom \
kmod-leds-gpio kmod-gpio-button-hotplug \
- kmod-qca-nss-dp \
+ kmod-phy-aquantia kmod-qca-nss-dp \
ath11k-firmware-ipq8074 kmod-ath11k-ahb \
wpad-basic-mbedtls uboot-envtools
diff --git a/target/linux/ipq807x/config-5.15 b/target/linux/ipq807x/config-5.15
index 923cd935f3..6ab29ebbe6 100644
--- a/target/linux/ipq807x/config-5.15
+++ b/target/linux/ipq807x/config-5.15
@@ -1,7 +1,6 @@
CONFIG_64BIT=y
# CONFIG_APQ_GCC_8084 is not set
# CONFIG_APQ_MMCC_8084 is not set
-CONFIG_AQUANTIA_PHY=y
CONFIG_ARCH_DMA_ADDR_T_64BIT=y
CONFIG_ARCH_HIBERNATION_POSSIBLE=y
CONFIG_ARCH_KEEP_MEMBLOCK=y