aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
authorBrian Norris <computersforpeace@gmail.com>2023-01-12 21:32:17 -0800
committerChristian Marangi <ansuelsmth@gmail.com>2023-01-21 01:02:24 +0100
commit84ee3436a44dac3809b05a1c900e34dbebf030c1 (patch)
tree94e271a4333e0eabd61b62913d3b990ed3f02759 /target/linux/ipq806x/image
parentd3c19c71f6044eff1677563365cea0f9e919b462 (diff)
downloadupstream-84ee3436a44dac3809b05a1c900e34dbebf030c1.tar.gz
upstream-84ee3436a44dac3809b05a1c900e34dbebf030c1.tar.bz2
upstream-84ee3436a44dac3809b05a1c900e34dbebf030c1.zip
ipq806x: Point to externally compiled dtbs in recipes
Similar to commit 4d8b42d8a777 ("ipq40xx: point to externally compiled dtbs in recipes"). Currently, we patch our DTS files into the kernel source tree, so the kernel build process will produce DTBs for us. The kernel-to-DTS dependency can cause buildroot to perform excessive rebuilds of the kernel though, which slows down device development iteration. Buildroot also compiles DTBs on its own, to $(KDIR)/image-$(DEVICE_DTS).dtb. With small adjustments, we can leverage this, and stop patching DTS files into the kernel Makefile at the same time. Signed-off-by: Brian Norris <computersforpeace@gmail.com>
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index f4f829b35c..8c1fc88010 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -5,7 +5,6 @@ include $(INCLUDE_DIR)/image.mk
define Device/Default
PROFILES := Default
- KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_LOADADDR = 0x42208000
DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
DEVICE_DTS_CONFIG := config@1
@@ -22,13 +21,13 @@ endef
define Device/FitImage
KERNEL_SUFFIX := -fit-uImage.itb
- KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+ KERNEL = kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
KERNEL_NAME := Image
endef
define Device/FitImageLzma
KERNEL_SUFFIX := -fit-uImage.itb
- KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+ KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb
KERNEL_NAME := Image
endef