aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorStefan Lippers-Hollmann <s.l-h@gmx.de>2018-05-18 03:00:41 +0200
committerJohn Crispin <john@phrozen.org>2018-05-22 20:34:14 +0200
commitdc50694bd1a8f81b40c185bc8cacbdc8e821a3c6 (patch)
tree55b907b6455517d9514ab5417158f13bcd37302e /target/linux/ipq806x/image/Makefile
parent7ac6697fe269e7915e2dd55ba872cffcc102338b (diff)
downloadupstream-dc50694bd1a8f81b40c185bc8cacbdc8e821a3c6.tar.gz
upstream-dc50694bd1a8f81b40c185bc8cacbdc8e821a3c6.tar.bz2
upstream-dc50694bd1a8f81b40c185bc8cacbdc8e821a3c6.zip
ipq806x: increase kernel partition size for the Netgear r7800
Starting with kernel 4.14 and gcc 7, the kernel doesn't fit into the 2 MB reserved for the kernel partition by the OEM firmware anymore. This patch increases the kernel partition from 2 MB to 4 MB, at the expense of the rootfs, for all supported kernels. WARNING: This breaks sysupgrade! Flashing a firmware containing this changed partitioning from an older image with 2 MB reserved for the kernel partion requires the tftp recovery procedure, thereby losing all settings. This patch is based on a corresponding change by Pavel Kubelun <be.dissent@gmail.com> and has been tested by Michael Yartys <michael.yartys@protonmail.com> Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index a737e165b0..e5df7275a1 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -149,7 +149,7 @@ TARGET_DEVICES += netgear_r7500v2
define Device/netgear_r7800
$(call Device/DniImage)
DEVICE_DTS := qcom-ipq8065-r7800
- KERNEL_SIZE := 2097152
+ KERNEL_SIZE := 4194304
NETGEAR_BOARD_ID := R7800
NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4+cascade
BLOCKSIZE := 128k