aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2017-12-31 16:48:17 -0300
committerMathias Kresin <dev@kresin.me>2018-01-13 07:33:02 +0100
commit3cbdae242161db64ffe039a042afb7e0349cb2e3 (patch)
treeef1dd130a7d1df191933a424ac94b487bfe5ee99 /target/linux/ipq806x/image/Makefile
parent09e13bd341da40af41e0dede8f4dcbf5ea87aefb (diff)
downloadupstream-3cbdae242161db64ffe039a042afb7e0349cb2e3.tar.gz
upstream-3cbdae242161db64ffe039a042afb7e0349cb2e3.tar.bz2
upstream-3cbdae242161db64ffe039a042afb7e0349cb2e3.zip
ipq806x: sync image filename with dt compatible string
Use <manufacturer>_<modelname> as image name for board using the devicetree compat string as boardname. Signed-off-by: Luis Araneda <luaraneda@gmail.com>
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile56
1 files changed, 28 insertions, 28 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 2e6cb0922e..afd79439d8 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -98,7 +98,7 @@ define Device/ZyXELImage
IMAGE/mmcblk0p4-kernel.bin := append-kernel
endef
-define Device/AP148
+define Device/qcom_ipq8064-ap148
$(call Device/FitImage)
$(call Device/UbiFit)
DEVICE_DTS := qcom-ipq8064-ap148
@@ -109,9 +109,9 @@ define Device/AP148
DEVICE_TITLE := Qualcomm AP148
DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
-TARGET_DEVICES += AP148
+TARGET_DEVICES += qcom_ipq8064-ap148
-define Device/AP148-legacy
+define Device/qcom_ipq8064-ap148-legacy
$(call Device/LegacyImage)
$(call Device/UbiFit)
DEVICE_DTS := qcom-ipq8064-ap148
@@ -121,9 +121,9 @@ define Device/AP148-legacy
DEVICE_TITLE := Qualcomm AP148 (legacy)
DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
-TARGET_DEVICES += AP148-legacy
+TARGET_DEVICES += qcom_ipq8064-ap148-legacy
-define Device/C2600
+define Device/tplink_c2600
$(call Device/TpSafeImage)
DEVICE_DTS := qcom-ipq8064-c2600
BLOCKSIZE := 128k
@@ -133,9 +133,9 @@ define Device/C2600
DEVICE_TITLE := TP-Link Archer C2600
DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
-TARGET_DEVICES += C2600
+TARGET_DEVICES += tplink_c2600
-define Device/D7800
+define Device/netgear_d7800
$(call Device/DniImage)
DEVICE_DTS := qcom-ipq8064-d7800
KERNEL_SIZE := 2097152
@@ -147,9 +147,9 @@ define Device/D7800
DEVICE_TITLE := Netgear Nighthawk X4 D7800
DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
-TARGET_DEVICES += D7800
+TARGET_DEVICES += netgear_d7800
-define Device/DB149
+define Device/qcom_ipq8064-db149
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq8064-db149
KERNEL_INSTALL := 1
@@ -157,9 +157,9 @@ define Device/DB149
DEVICE_TITLE := Qualcomm DB149
DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
-TARGET_DEVICES += DB149
+TARGET_DEVICES += qcom_ipq8064-db149
-define Device/EA8500
+define Device/linksys_ea8500
$(call Device/LegacyImage)
DEVICE_DTS := qcom-ipq8064-ea8500
PAGESIZE := 2048
@@ -175,9 +175,9 @@ define Device/EA8500
DEVICE_TITLE := Linksys EA8500
DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
-TARGET_DEVICES += EA8500
+TARGET_DEVICES += linksys_ea8500
-define Device/FRITZ4040
+define Device/avm_fritzbox-4040
$(call Device/FitImageLzma)
DEVICE_DTS := qcom-ipq4019-fritz4040
KERNEL_LOADADDR := 0x80208000
@@ -190,9 +190,9 @@ define Device/FRITZ4040
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
DEVICE_PACKAGES := kmod-usb-phy-qcom-ipq4019 ipq-wifi-fritz4040 fritz-tffs fritz-caldata u-boot-fritz4040
endef
-TARGET_DEVICES += FRITZ4040
+TARGET_DEVICES += avm_fritzbox-4040
-define Device/R7500
+define Device/netgear_r7500
$(call Device/DniImage)
DEVICE_DTS := qcom-ipq8064-r7500
KERNEL_SIZE := 2097152
@@ -204,9 +204,9 @@ define Device/R7500
DEVICE_TITLE := Netgear Nighthawk X4 R7500
DEVICE_PACKAGES := ath10k-firmware-qca988x
endef
-TARGET_DEVICES += R7500
+TARGET_DEVICES += netgear_r7500
-define Device/R7500v2
+define Device/netgear_r7500v2
$(call Device/DniImage)
DEVICE_DTS := qcom-ipq8064-r7500v2
KERNEL_SIZE := 2097152
@@ -218,9 +218,9 @@ define Device/R7500v2
DEVICE_TITLE := Netgear Nighthawk X4 R7500v2
DEVICE_PACKAGES := ath10k-firmware-qca99x0 ath10k-firmware-qca988x
endef
-TARGET_DEVICES += R7500v2
+TARGET_DEVICES += netgear_r7500v2
-define Device/R7800
+define Device/netgear_r7800
$(call Device/DniImage)
DEVICE_DTS := qcom-ipq8065-r7800
KERNEL_SIZE := 2097152
@@ -232,9 +232,9 @@ define Device/R7800
DEVICE_TITLE := Netgear Nighthawk X4S R7800
DEVICE_PACKAGES := ath10k-firmware-qca9984
endef
-TARGET_DEVICES += R7800
+TARGET_DEVICES += netgear_r7800
-define Device/NBG6817
+define Device/zyxel_nbg6817
DEVICE_DTS := qcom-ipq8065-nbg6817
KERNEL_SIZE := 4096k
BLOCKSIZE := 64k
@@ -243,9 +243,9 @@ define Device/NBG6817
DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs kmod-fs-ext4 losetup
$(call Device/ZyXELImage)
endef
-TARGET_DEVICES += NBG6817
+TARGET_DEVICES += zyxel_nbg6817
-define Device/VR2600v
+define Device/tplink_vr2600v
PROFILES += $$(DEVICE_NAME)
FILESYSTEMS := squashfs
KERNEL_SUFFIX := -uImage
@@ -261,9 +261,9 @@ define Device/VR2600v
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
endef
-TARGET_DEVICES += VR2600v
+TARGET_DEVICES += tplink_vr2600v
-define Device/AP-DK01.1-C1
+define Device/qcom_ap-dk01.1-c1
PROFILES += $$(DEVICE_NAME)
DEVICE_TITLE := QCA AP-DK01.1-C1
BOARD_NAME := ap-dk01.1-c1
@@ -278,9 +278,9 @@ define Device/AP-DK01.1-C1
IMAGE/sysupgrade.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
DEVICE_PACKAGES := ath10k-firmware-qca4019
endef
-TARGET_DEVICES += AP-DK01.1-C1
+TARGET_DEVICES += qcom_ap-dk01.1-c1
-define Device/AP-DK04.1-C1
+define Device/qcom_ap-dk04.1-c1
$(call Device/FitImage)
$(call Device/UbiFit)
DEVICE_DTS := qcom-ipq4019-ap.dk04.1-c1
@@ -292,6 +292,6 @@ define Device/AP-DK04.1-C1
BOARD_NAME := ap-dk04.1-c1
DEVICE_TITLE := QCA AP-DK04.1-C1
endef
-TARGET_DEVICES += AP-DK04.1-C1
+TARGET_DEVICES += qcom_ap-dk04.1-c1
$(eval $(call BuildImage))