aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-10 11:47:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-10 11:47:02 +0000
commitc6c8c1b3576f09708151b67d228fe20c77a4a1e3 (patch)
tree0ed7b973f21cb43f4fa35af8ee88b55858a03e0f /target/linux/ipq806x/Makefile
parent2fb73fa3e40221354e6d3c80878d06fb2bc98164 (diff)
downloadupstream-c6c8c1b3576f09708151b67d228fe20c77a4a1e3.tar.gz
upstream-c6c8c1b3576f09708151b67d228fe20c77a4a1e3.tar.bz2
upstream-c6c8c1b3576f09708151b67d228fe20c77a4a1e3.zip
ipq806x: add support for zImage kernel
This change enable zImage+appended dtb support in ipq806x kernel options. The zImage will now be generated as part of the kernel binaries. Platforms which do not have DT support enabled in U-boot can now make use of it by generating zImage files and appending dtb to it. It is not used yet but it is done as a stepping stone for early IPQ806x platforms, which did not include DT support in U-boot. Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45662 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ipq806x/Makefile')
-rw-r--r--target/linux/ipq806x/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq806x/Makefile b/target/linux/ipq806x/Makefile
index 1512b30c03..f97db74fc3 100644
--- a/target/linux/ipq806x/Makefile
+++ b/target/linux/ipq806x/Makefile
@@ -11,7 +11,7 @@ MAINTAINER:=John Crispin <blogic@openwrt.org>
KERNEL_PATCHVER:=3.18
-KERNELNAME:=Image dtbs
+KERNELNAME:=zImage Image dtbs
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \