aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2021-01-21 13:08:57 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-21 17:08:16 +0100
commit36347d003a934372bf10e59645121ba387a6d27e (patch)
tree079e1e365b56fd94dc53d67abc01b0c64d21c26e /target/linux/ipq40xx
parent3bd8f660a4b967a25aa7b605f0ead44ddfab9ea4 (diff)
downloadupstream-36347d003a934372bf10e59645121ba387a6d27e.tar.gz
upstream-36347d003a934372bf10e59645121ba387a6d27e.tar.bz2
upstream-36347d003a934372bf10e59645121ba387a6d27e.zip
ipq40xx: fix boards being shown twice
Since generic images have been split to their own Makefile boards are showing up twice in menuconfig as $(eval $(call BuildImage)) was not dropped from the new generic.mk. Hence $(eval $(call BuildImage)) was being called twice. So, lets simply drop it from generic.mk. Fixes: 378c7ff28210 ("ipq40xx: split generic images into own file") Signed-off-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'target/linux/ipq40xx')
-rw-r--r--target/linux/ipq40xx/image/generic.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 9cd50e23ff..4e40b8be50 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -805,5 +805,3 @@ define Device/zyxel_wre6606
DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
TARGET_DEVICES += zyxel_wre6606
-
-$(eval $(call BuildImage))