aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/patches-5.4/710-net-add-qualcomm-essedma-ethernet-driver.patch
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2020-02-28 21:15:48 +0100
committerChristian Lamparter <chunkeey@gmail.com>2020-02-28 22:46:27 +0100
commit91a7c9c27d2e0d88e73735f865c83894a8a32555 (patch)
treef236a031d9aaeef1865f1611f70304efe4235773 /target/linux/ipq40xx/patches-5.4/710-net-add-qualcomm-essedma-ethernet-driver.patch
parente48465bdd863e6a4cf44703d85d595378b61e791 (diff)
downloadupstream-91a7c9c27d2e0d88e73735f865c83894a8a32555.tar.gz
upstream-91a7c9c27d2e0d88e73735f865c83894a8a32555.tar.bz2
upstream-91a7c9c27d2e0d88e73735f865c83894a8a32555.zip
ipq40xx: 5.4: refresh patches and config
This patch just refreshes the 5.4 patches. It seems as if 070-v4.20-soc-qcom-spm-add-SCM-probe-dependency.patch is already applied, so drop it. It also does a quick make kernel_oldconfig to get rid of unneeded symbols. [Looks like USB and Ethernet need some more work]. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/patches-5.4/710-net-add-qualcomm-essedma-ethernet-driver.patch')
-rw-r--r--target/linux/ipq40xx/patches-5.4/710-net-add-qualcomm-essedma-ethernet-driver.patch12
1 files changed, 4 insertions, 8 deletions
diff --git a/target/linux/ipq40xx/patches-5.4/710-net-add-qualcomm-essedma-ethernet-driver.patch b/target/linux/ipq40xx/patches-5.4/710-net-add-qualcomm-essedma-ethernet-driver.patch
index 1df0a89951..657d81c5c2 100644
--- a/target/linux/ipq40xx/patches-5.4/710-net-add-qualcomm-essedma-ethernet-driver.patch
+++ b/target/linux/ipq40xx/patches-5.4/710-net-add-qualcomm-essedma-ethernet-driver.patch
@@ -9,10 +9,8 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
drivers/net/ethernet/qualcomm/Makefile | 1 +
2 files changed, 10 insertions(+)
-Index: linux-5.4.11/drivers/net/ethernet/qualcomm/Kconfig
-===================================================================
---- linux-5.4.11.orig/drivers/net/ethernet/qualcomm/Kconfig
-+++ linux-5.4.11/drivers/net/ethernet/qualcomm/Kconfig
+--- a/drivers/net/ethernet/qualcomm/Kconfig
++++ b/drivers/net/ethernet/qualcomm/Kconfig
@@ -62,4 +62,13 @@ config QCOM_EMAC
source "drivers/net/ethernet/qualcomm/rmnet/Kconfig"
@@ -27,10 +25,8 @@ Index: linux-5.4.11/drivers/net/ethernet/qualcomm/Kconfig
+ will be called essedma.ko.
+
endif # NET_VENDOR_QUALCOMM
-Index: linux-5.4.11/drivers/net/ethernet/qualcomm/Makefile
-===================================================================
---- linux-5.4.11.orig/drivers/net/ethernet/qualcomm/Makefile
-+++ linux-5.4.11/drivers/net/ethernet/qualcomm/Makefile
+--- a/drivers/net/ethernet/qualcomm/Makefile
++++ b/drivers/net/ethernet/qualcomm/Makefile
@@ -10,5 +10,6 @@ obj-$(CONFIG_QCA7000_UART) += qcauart.o
qcauart-objs := qca_uart.o