aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2021-01-05 00:22:00 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-12-02 19:46:14 +0000
commit8d623047851337c4507f77b51f47851988c0f53c (patch)
tree848bf1a4560dd13c1d730827bf2224a27bf4862d /target/linux/ipq40xx/image
parentab241e0937c9cea4ae606f204ce82749373611f0 (diff)
downloadupstream-8d623047851337c4507f77b51f47851988c0f53c.tar.gz
upstream-8d623047851337c4507f77b51f47851988c0f53c.tar.bz2
upstream-8d623047851337c4507f77b51f47851988c0f53c.zip
ipq40xx: add MikroTik LHGG-60ad outdoor 802.11ad (60GHz) dish
LHGG-60ad is IPQ4019 + wil6210 based. Specification: - Qualcomm IPQ4019 (717 MHz) - 256 MB of RAM (DDR3L) - 16 MB (SPI NOR) of flash - 1x Gbit ethernet, 802.3af/at POE IN connected through AR8035. - WLAN: wil6210 802.11ad PCI card - No USB or SD card ports - UART disabled - 8x LEDs Biggest news is the wil6210 PCI card. Integration for its configuration and detection has already been taken care of when adding support for TP-Link Talon AD7200. However, signal quality is much lower than with stock firmware, so probably additional board-specific data has to be provided to the driver and is still missing at the moment. Signed-off-by: Robert Marko <robimarko@gmail.com> Signed-off-by: Alexander Couzens <lynxis@fe80.eu> Signed-off-by: Daniel Golle <daniel@makrotopia.org> [Fix Ethernet Interface] Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/mikrotik.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/mikrotik.mk b/target/linux/ipq40xx/image/mikrotik.mk
index bfff58597f..2fdaad60ab 100644
--- a/target/linux/ipq40xx/image/mikrotik.mk
+++ b/target/linux/ipq40xx/image/mikrotik.mk
@@ -40,6 +40,14 @@ define Device/mikrotik_hap-ac3
endef
TARGET_DEVICES += mikrotik_hap-ac3
+define Device/mikrotik_lhgg-60ad
+ $(call Device/mikrotik_nor)
+ DEVICE_MODEL := Wireless Wire Dish LHGG-60ad
+ DEVICE_DTS := qcom-ipq4019-lhgg-60ad
+ DEVICE_PACKAGES += -kmod-ath10k-ct -ath10k-firmware-qca4019-ct kmod-wil6210
+endef
+TARGET_DEVICES += mikrotik_lhgg-60ad
+
define Device/mikrotik_sxtsq-5-ac
$(call Device/mikrotik_nor)
DEVICE_MODEL := SXTsq 5 ac (RBSXTsqG-5acD)