aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2021-10-09 20:13:25 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-28 17:19:52 +0100
commit3ad229db0b0ed8538eadcdc2a1c3faf964f239be (patch)
treec21ed618c52063673af09c8ba7a18bef57de68d2 /target/linux/ipq40xx/image
parentf2c4064ecb76bca69d4ce3fbc52209992f2334dc (diff)
downloadupstream-3ad229db0b0ed8538eadcdc2a1c3faf964f239be.tar.gz
upstream-3ad229db0b0ed8538eadcdc2a1c3faf964f239be.tar.bz2
upstream-3ad229db0b0ed8538eadcdc2a1c3faf964f239be.zip
ipq40xx: add support for MikroTik hAP ac3
This adds support for the MikroTik RouterBOARD RBD53iG-5HacD2HnD (hAP ac³), a indoor dual band, dual-radio 802.11ac wireless AP with external omnidirectional antennae, USB port, five 10/100/1000 Mbps Ethernet ports and PoE passthrough. See https://mikrotik.com/product/hap_ac3 for more info. Specifications: - SoC: Qualcomm Atheros IPQ4019 - RAM: 256 MB - Storage: 16 MB NOR + 128 MB NAND - Wireless: · Built-in IPQ4019 (SoC) 802.11b/g/n 2x2:2, 3 dBi antennae · Built-in IPQ4019 (SoC) 802.11a/n/ac 2x2:2, 5.5 dBi antennae - Ethernet: Built-in IPQ4019 (SoC, QCA8075) , 5x 1000/100/10 port, passive PoE in, PoE passtrough on port 5 - 1x USB Type A port Installation: 1. Boot the initramfs image via TFTP 2. Run "cat /proc/mtd" and look for "ubi" partition mtd device number, ex. "mtd1" 3. Use ubiformat to remove MikroTik specific UBI volumes * Detach the UBI partition by running: "ubidetach -d 0" * Format the partition by running: "ubiformat /dev/mtdN -y" Replace mtdN with the correct mtd index from step 2. 3. Flash the sysupgrade image using "sysupgrade -n" Signed-off-by: Robert Marko <robimarko@gmail.com> Tested-by: Mark Birss <markbirss@gmail.com> Tested-by: Michael Büchler <michael.buechler@posteo.net> Tested-by: Alex Tomkins <tomkins@darkzone.net>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/mikrotik.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/mikrotik.mk b/target/linux/ipq40xx/image/mikrotik.mk
index 31497608be..bfff58597f 100644
--- a/target/linux/ipq40xx/image/mikrotik.mk
+++ b/target/linux/ipq40xx/image/mikrotik.mk
@@ -10,6 +10,16 @@ define Device/mikrotik_nor
check-size | append-metadata
endef
+define Device/mikrotik_nand
+ DEVICE_VENDOR := MikroTik
+ KERNEL_NAME := vmlinux
+ KERNEL_INITRAMFS := kernel-bin | append-dtb-elf
+ KERNEL := kernel-bin | append-dtb-elf | package-kernel-ubifs | \
+ ubinize-kernel
+ IMAGES := nand-sysupgrade.bin
+ IMAGE/nand-sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+
define Device/mikrotik_hap-ac2
$(call Device/mikrotik_nor)
DEVICE_MODEL := hAP ac2
@@ -19,6 +29,17 @@ define Device/mikrotik_hap-ac2
endef
TARGET_DEVICES += mikrotik_hap-ac2
+define Device/mikrotik_hap-ac3
+ $(call Device/mikrotik_nand)
+ DEVICE_MODEL := hAP ac3
+ SOC := qcom-ipq4019
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_UBIFS_OPTS = -m $$(PAGESIZE) -e 124KiB -c $$(PAGESIZE) -x none
+ DEVICE_PACKAGES := kmod-ledtrig-gpio ipq-wifi-mikrotik_hap-ac3
+endef
+TARGET_DEVICES += mikrotik_hap-ac3
+
define Device/mikrotik_sxtsq-5-ac
$(call Device/mikrotik_nor)
DEVICE_MODEL := SXTsq 5 ac (RBSXTsqG-5acD)