aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/Makefile
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-10 15:41:09 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-21 19:55:12 +0100
commit5b392c7119f23aef10ffc0def9a70e8335f9f3f8 (patch)
tree73e56336895a2944f0cb8dfedfd04f7b7d7d6e67 /target/linux/ipq40xx/image/Makefile
parentd5812478ad4c882256e43a2ad52ddf0c0944db7b (diff)
downloadupstream-5b392c7119f23aef10ffc0def9a70e8335f9f3f8.tar.gz
upstream-5b392c7119f23aef10ffc0def9a70e8335f9f3f8.tar.bz2
upstream-5b392c7119f23aef10ffc0def9a70e8335f9f3f8.zip
treewide: gather DEVICE_VARS into one place
Place DEVICE_VARS assignments at the top of the file or above Device/Default to make them easier to find. For ramips, remove redundant values already present in parent file. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ipq40xx/image/Makefile')
-rw-r--r--target/linux/ipq40xx/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 2e95ad4dfb..1cd7650881 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -1,8 +1,9 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION \
- WRGG_DEVNAME WRGG_SIGNATURE
+DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
+DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION
+DEVICE_VARS += WRGG_DEVNAME WRGG_SIGNATURE
define Device/Default
PROFILES := Default
@@ -51,7 +52,6 @@ define Device/DniImage
IMAGE/factory.img := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | append-rootfs | pad-rootfs | netgear-dni
IMAGE/sysupgrade.bin := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | append-rootfs | pad-rootfs | append-metadata
endef
-DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
define Build/mkmylofw_32m
$(eval device_id=$(word 1,$(1)))