aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2018-11-23 09:25:13 +0100
committerPetr Štetiar <ynezz@true.cz>2019-04-08 18:37:03 +0200
commitdc1a73984e640ded21c7fe1abc8de2d5585ae0bd (patch)
treea4374e9abe09d0c8ef4bfbf21882b147dd5fbb83 /target/linux/imx6
parentadb0a420e56e6dd721f8fa49c8ac66ceb412a58a (diff)
downloadupstream-dc1a73984e640ded21c7fe1abc8de2d5585ae0bd.tar.gz
upstream-dc1a73984e640ded21c7fe1abc8de2d5585ae0bd.tar.bz2
upstream-dc1a73984e640ded21c7fe1abc8de2d5585ae0bd.zip
imx6: image: Split imx6-sdcard image for reusability
I'm going to reuse the imx6-sdcard image commands for building of Apalis eMMC images. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/image/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 9dd5b520a1..fa10b756a1 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -58,11 +58,16 @@ define Build/boot-scr
$(BIN_DIR)/boot.scr
endef
-define Build/imx6-sdcard
+define Build/imx6-combined-image-prepare
rm -rf $@.boot
mkdir -p $@.boot
+endef
- $(CP) $(STAGING_DIR_IMAGE)/$(UBOOT)-u-boot.img $@.boot/u-boot.img
+define Build/imx6-combined-image-clean
+ rm -rf $@.boot $@.fs
+endef
+
+define Build/imx6-combined-image
$(CP) $(IMAGE_KERNEL) $@.boot/uImage
$(foreach dts,$(DEVICE_DTS), \
@@ -84,10 +89,18 @@ define Build/imx6-sdcard
$(CONFIG_TARGET_ROOTFS_PARTSIZE) \
$@.fs \
1024
+endef
+define Build/imx6-sdcard
+ $(Build/imx6-combined-image-prepare)
+
+ $(CP) $(STAGING_DIR_IMAGE)/$(UBOOT)-u-boot.img $@.boot/u-boot.img
+ $(Build/imx6-combined-image)
dd if=$(STAGING_DIR_IMAGE)/$(UBOOT)-SPL of=$@ bs=1024 seek=1 conv=notrunc
- rm -rf $@.boot $@.fs
+ $(Build/imx6-combined-image-clean)
+endef
+
endef
#################################################