aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2021-05-26 12:36:30 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2021-05-26 14:12:46 +0200
commit8dba71dd33c8e35e7f363ffdb2ba42259ab43ce2 (patch)
tree5f355d0d316a48324353b1bd15ed0945f73532e7 /target/linux/imx6
parentfbd6f099f50e77d2bb95708c62e86a358779251a (diff)
downloadupstream-8dba71dd33c8e35e7f363ffdb2ba42259ab43ce2.tar.gz
upstream-8dba71dd33c8e35e7f363ffdb2ba42259ab43ce2.tar.bz2
upstream-8dba71dd33c8e35e7f363ffdb2ba42259ab43ce2.zip
imx6: image: drop BOOT_SCRIPT and fix DEVICE_NAME
This fixes Gateworks Ventana 'DEVICE_NAME' variable which value wasn't adjusted during migration to common 'vendor_model' image naming scheme (fixes: FS#3825). Furthermore, drop unused 'Build/boot-scr' recipe, get rid of redundant 'BOOT_SCRIPT' variable (use already provided 'DEVICE_NAME' instead) and drop custom 'DEVICE_NAME' variable from SolidRun CuBox-i image recipe (use default one instead). Fixes: cbc8bcfbaa ("imx6: image: use vendor_model scheme") Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/image/Makefile17
-rw-r--r--target/linux/imx6/image/bootscript-solidrun_cubox-i (renamed from target/linux/imx6/image/bootscript-solidrun_cubox)0
2 files changed, 3 insertions, 14 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 96d6a1caf9..948694381e 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
# Images
#################################################
-DEVICE_VARS += MKUBIFS_OPTS UBOOT BOOT_SCRIPT
+DEVICE_VARS += MKUBIFS_OPTS UBOOT
define Build/boot-overlay
rm -rf $@.boot
@@ -49,13 +49,6 @@ define Build/bootfs.tar.gz
-czvf $@ .
endef
-define Build/boot-scr
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
- -n '$(DEVICE_ID) OpenWrt bootscript' \
- -d ./bootscript-$(DEVICE_NAME) \
- $(BIN_DIR)/boot.scr
-endef
-
define Build/recovery-scr
mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
-n '$(DEVICE_ID) OpenWrt recovery bootscript' \
@@ -82,7 +75,7 @@ define Build/imx6-combined-image
mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
-n '$(DEVICE_ID) OpenWrt bootscript' \
- -d $(BOOT_SCRIPT) \
+ -d bootscript-$(DEVICE_NAME) \
$@.boot/boot.scr
cp $@ $@.fs
@@ -131,7 +124,7 @@ define Device/gateworks_ventana
DEVICE_VENDOR := Gateworks
DEVICE_MODEL := Ventana family
DEVICE_VARIANT := normal NAND flash
- DEVICE_NAME := ventana
+ DEVICE_NAME := gateworks_ventana
DEVICE_DTS:= \
imx6dl-gw51xx \
imx6dl-gw52xx \
@@ -161,7 +154,6 @@ define Device/gateworks_ventana
DEVICE_PACKAGES := kmod-sky2 kmod-sound-core kmod-sound-soc-imx \
kmod-sound-soc-imx-sgtl5000 kmod-can kmod-can-flexcan kmod-can-raw \
kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio kobs-ng
- BOOT_SCRIPT := bootscript-gateworks_ventana
KERNEL += | boot-overlay
IMAGES := nand.ubi bootfs.tar.gz dtb
IMAGE/nand.ubi := append-ubi
@@ -187,14 +179,12 @@ TARGET_DEVICES += gateworks_ventana-large
define Device/solidrun_cubox-i
DEVICE_VENDOR := SolidRun
DEVICE_MODEL := CuBox-i
- DEVICE_NAME := cubox
DEVICE_DTS := \
imx6q-cubox-i \
imx6dl-cubox-i \
imx6q-hummingboard \
imx6dl-hummingboard
DEVICE_PACKAGES := kmod-drm-imx kmod-drm-imx-hdmi kmod-usb-hid
- BOOT_SCRIPT := bootscript-solidrun_cubox
UBOOT := mx6cuboxi
KERNEL := kernel-bin
KERNEL_SUFFIX := -zImage
@@ -217,7 +207,6 @@ define Device/toradex_apalis
kmod-can kmod-can-flexcan kmod-can-raw \
kmod-leds-gpio kmod-gpio-button-hotplug \
kmod-pps-gpio kmod-rtc-ds1307
- BOOT_SCRIPT := bootscript-toradex_apalis
FILESYSTEMS := squashfs
IMAGES := combined.bin sysupgrade.bin
DEVICE_IMG_NAME = $$(DEVICE_IMG_PREFIX)-$$(1).$$(2)
diff --git a/target/linux/imx6/image/bootscript-solidrun_cubox b/target/linux/imx6/image/bootscript-solidrun_cubox-i
index 2ed48ab941..2ed48ab941 100644
--- a/target/linux/imx6/image/bootscript-solidrun_cubox
+++ b/target/linux/imx6/image/bootscript-solidrun_cubox-i