aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/profiles/100-default.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-09-05 09:52:57 +0200
committerFelix Fietkau <nbd@nbd.name>2018-09-05 10:00:01 +0200
commitb9f926e15146bcb3688d66562fd0f1a3e79ca747 (patch)
tree69e2760d27636b7294f932e4ffe65203d7997e73 /target/linux/imx6/profiles/100-default.mk
parent4ccbe7de6cb20766fd309bc3824c7591e33b0b96 (diff)
downloadupstream-b9f926e15146bcb3688d66562fd0f1a3e79ca747.tar.gz
upstream-b9f926e15146bcb3688d66562fd0f1a3e79ca747.tar.bz2
upstream-b9f926e15146bcb3688d66562fd0f1a3e79ca747.zip
imx6: rename Generic profile to Default, fixes u-boot image build issue
u-boot.mk checks for the Default profile to build images for all targets. This brings the target default profile in sync with other targets Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/imx6/profiles/100-default.mk')
-rw-r--r--target/linux/imx6/profiles/100-default.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/imx6/profiles/100-default.mk b/target/linux/imx6/profiles/100-default.mk
new file mode 100644
index 0000000000..60b3ef538b
--- /dev/null
+++ b/target/linux/imx6/profiles/100-default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ PRIORITY:=1
+ NAME:=Default Profile
+endef
+
+define Profile/Default/Description
+ Package set compatible with most Freescale i.MX 6 based boards.
+endef
+
+$(eval $(call Profile,Default))