aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/patches-4.4/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-15 15:18:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-15 15:18:18 +0000
commit321823ba05d79198931217df1489d36e27eaeb3c (patch)
tree4ee17dd0af896d2345fc2426719dea10c4742fa5 /target/linux/imx6/patches-4.4/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch
parent82c5e2c497c69dca32a59090cddf5f298aa94e01 (diff)
downloadupstream-321823ba05d79198931217df1489d36e27eaeb3c.tar.gz
upstream-321823ba05d79198931217df1489d36e27eaeb3c.tar.bz2
upstream-321823ba05d79198931217df1489d36e27eaeb3c.zip
imx6: add 4.4 support
Build and boot tested on the following hardware: * GW54xx * GW53xx * GW52xx * GW51xx * GW552x * GW551x Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com> SVN-Revision: 48248
Diffstat (limited to 'target/linux/imx6/patches-4.4/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch')
-rw-r--r--target/linux/imx6/patches-4.4/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/imx6/patches-4.4/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch b/target/linux/imx6/patches-4.4/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch
new file mode 100644
index 0000000000..fa9a8c3a0a
--- /dev/null
+++ b/target/linux/imx6/patches-4.4/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch
@@ -0,0 +1,27 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -336,6 +336,14 @@ endif # RTL8366_SMI
+
+ source "drivers/net/phy/b53/Kconfig"
+
++config GATEWORKS_GW16083
++ tristate "Gateworks GW16083 Ethernet Expansion Mezzanine"
++ ---help---
++ The Gateworks GW16083 Ethernet Expansion Mezzanine connects to a
++ Gateworks Ventana baseboard and provides a 7-port GbE managed
++ Ethernet switch with 4 dedicated GbE RJ45 ports, and 2 Gbe/SFP
++ ports"
++
+ endif # PHYLIB
+
+ config MICREL_KS8995MA
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -46,6 +46,7 @@ obj-$(CONFIG_DP83848_PHY) += dp83848.o
+ obj-$(CONFIG_DP83867_PHY) += dp83867.o
+ obj-$(CONFIG_STE10XP) += ste10Xp.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
++obj-$(CONFIG_GATEWORKS_GW16083) += gw16083.o
+ obj-$(CONFIG_MDIO_OCTEON) += mdio-octeon.o
+ obj-$(CONFIG_MICREL_KS8995MA) += spi_ks8995.o
+ obj-$(CONFIG_AT803X_PHY) += at803x.o