aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-02-27 22:41:39 +0000
committerLuka Perkov <luka@openwrt.org>2014-02-27 22:41:39 +0000
commit8a1b7ef11b7928abe73074c48758985ba9330351 (patch)
tree58e7ffc295b46e0fd3fdc2230c39371977a3a965 /target/linux/imx6/Makefile
parentc7c11c726cc75b98aaae4b67c11d90b6d352af0c (diff)
downloadupstream-8a1b7ef11b7928abe73074c48758985ba9330351.tar.gz
upstream-8a1b7ef11b7928abe73074c48758985ba9330351.tar.bz2
upstream-8a1b7ef11b7928abe73074c48758985ba9330351.zip
imx6: enable FPU for hard float
The OpenWrt build system uses MACHINE_FEATURES of fpu to set the HAS_FPU which in turn sets the default of CONFIG_SOFT_FLOAT as well as uClibc configuration. As the IMX6 SoC has both vfpv3 and NEON hardware support we want to add fpu to the feature list. This will default the IMX6 target to use -mfloat-abi=hard which will the be most efficient use of floating point. When switching to hard float, we also need to enable VFP support in the kernel. Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39759 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/imx6/Makefile')
-rw-r--r--target/linux/imx6/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index 9ae1a4b4db..cee5b45423 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=imx6
BOARDNAME:=Freescale i.MX 6 Series
-FEATURES:=audio display gpio pcie rtc usb usbgadget squashfs targz ubifs
+FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz ubifs
CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Luka Perkov <luka@openwrt.org>