aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx21/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-07-19 12:32:18 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-07-19 12:32:18 +0000
commitc2dfed1638e992c5fa552aae289d0ac754cb88fc (patch)
treea233ad5f2d6d2523bd28081fd153d1a9bef3a006 /target/linux/imx21/Makefile
parenteecb8493c78aa8acb9699e87c71be51424ed7b12 (diff)
downloadupstream-c2dfed1638e992c5fa552aae289d0ac754cb88fc.tar.gz
upstream-c2dfed1638e992c5fa552aae289d0ac754cb88fc.tar.bz2
upstream-c2dfed1638e992c5fa552aae289d0ac754cb88fc.zip
rename the mx2 target to imx21
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22294 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/imx21/Makefile')
-rw-r--r--target/linux/imx21/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/imx21/Makefile b/target/linux/imx21/Makefile
new file mode 100644
index 0000000000..96a2784537
--- /dev/null
+++ b/target/linux/imx21/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=imx21
+BOARDNAME:=Freescale i.MX21
+FEATURES:=jffs2
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+
+LINUX_VERSION:=2.6.34.1
+
+DEVICE_TYPE=phone
+
+define Target/Description
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))