aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-02-06 00:07:27 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-02-06 00:07:27 +0000
commit2cc350b51a00a545b77980700ab5e512dc79a786 (patch)
tree5a84def24b9d6da49169f9b7298ea27ee4146b03 /target/linux/image
parentba13899d9777ce3c7411f83c66b72dc5736ed017 (diff)
downloadupstream-2cc350b51a00a545b77980700ab5e512dc79a786.tar.gz
upstream-2cc350b51a00a545b77980700ab5e512dc79a786.tar.bz2
upstream-2cc350b51a00a545b77980700ab5e512dc79a786.zip
port the changes from [3155] to Kamikaze
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3156 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image')
-rw-r--r--target/linux/image/brcm/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/target/linux/image/brcm/Makefile b/target/linux/image/brcm/Makefile
index 494450f247..0fe3ceeac7 100644
--- a/target/linux/image/brcm/Makefile
+++ b/target/linux/image/brcm/Makefile
@@ -89,7 +89,16 @@ $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$
$(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
$(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.2 -i $< -o $@ -g
-install: $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54g3g-$(KERNEL)-$(FSNAME).bin
+$(BIN_DIR)/openwrt-wr850g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ $(STAGING_DIR)/bin/motorola-bin -1 $< $@
+
+$(BIN_DIR)/openwrt-wa840g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ $(STAGING_DIR)/bin/motorola-bin -2 $< $@
+
+$(BIN_DIR)/openwrt-we800g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ $(STAGING_DIR)/bin/motorola-bin -3 $< $@
+
+install: $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54g3g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wr850g-$(FSNAME).bin $(BIN_DIR)/openwrt-wa840g-$(FSNAME).bin $(BIN_DIR)/openwrt-we800g-$(FSNAME).bin
endif
ifneq ($(FS),jffs2-4MB)
@@ -100,12 +109,11 @@ $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-
$(BIN_DIR)/openwrt-wrt54gs-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
$(STAGING_DIR)/bin/addpattern -4 -p W54S -v v4.70.6 -i $< -o $@ -g
-install: $(BIN_DIR)/openwrt-wrt54gs-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin
-endif
+$(BIN_DIR)/openwrt-wrtsl54gs-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ $(STAGING_DIR)/bin/addpattern -4 -p W54U -v v2.00.0 -i $< -o $@ -g
-$(BIN_DIR)/openwrt-motorola-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
- $(STAGING_DIR)/bin/motorola-bin $< $@
-install: $(BIN_DIR)/openwrt-motorola-$(KERNEL)-$(FS).bin
+install: $(BIN_DIR)/openwrt-wrt54gs-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wgt634u-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrtsl54gs-$(FSNAME).bin
+endif
endif
ifeq ($(IB),)