aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/Makefile
diff options
context:
space:
mode:
authorThomas Langer <thomas.langer@lantiq.com>2009-03-04 14:46:02 +0000
committerThomas Langer <thomas.langer@lantiq.com>2009-03-04 14:46:02 +0000
commitd8f6369756277ecd571681f387fc319d0affdfe5 (patch)
treeb2685cc36ef09c0c452be581bb6d9940ff364a74 /target/linux/ifxmips/Makefile
parent552fbe65d436e325c29c038aa5c8c8b8e915a7fa (diff)
downloadupstream-d8f6369756277ecd571681f387fc319d0affdfe5.tar.gz
upstream-d8f6369756277ecd571681f387fc319d0affdfe5.tar.bz2
upstream-d8f6369756277ecd571681f387fc319d0affdfe5.zip
move kernel support to 2.6.28.7
SVN-Revision: 14747
Diffstat (limited to 'target/linux/ifxmips/Makefile')
-rw-r--r--target/linux/ifxmips/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/target/linux/ifxmips/Makefile b/target/linux/ifxmips/Makefile
index fde4d74d8e..27ea078fb8 100644
--- a/target/linux/ifxmips/Makefile
+++ b/target/linux/ifxmips/Makefile
@@ -10,9 +10,8 @@ ARCH:=mips
BOARD:=ifxmips
BOARDNAME:=Infineon Mips
FEATURES:=squashfs jffs2
-SUBTARGETS:=generic nfs
-LINUX_VERSION:=2.6.26.8
-#LINUX_VERSION:=2.6.27.19
+
+LINUX_VERSION:=2.6.28.7
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
@@ -21,4 +20,11 @@ define Target/Description
Build firmware images for Infineon Mips Controllers
endef
+ifeq ($(KERNEL_PATCHVER),2.6.28)
+ define Kernel/Prepare
+ $(call Kernel/Prepare/Default)
+ mv $(LINUX_DIR)/include/asm-mips/* $(LINUX_DIR)/arch/mips/include/asm/
+ endef
+endif
+
$(eval $(call BuildTarget))