aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/goldfish/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-06-14 20:42:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-06-14 20:42:33 +0000
commitf88360279f91387dc61725226ad38c3c95d3790a (patch)
tree66d21f3483914eb7e674c45f3497ab8912094ac0 /target/linux/goldfish/Makefile
parenta6d8f8be9e06c5ffb03f815c8c76ba743c64aa3d (diff)
downloadupstream-f88360279f91387dc61725226ad38c3c95d3790a.tar.gz
upstream-f88360279f91387dc61725226ad38c3c95d3790a.tar.bz2
upstream-f88360279f91387dc61725226ad38c3c95d3790a.zip
add the 'goldfish' target, useful for experimenting with virtual phone hardware (includes the emulator)
SVN-Revision: 16459
Diffstat (limited to 'target/linux/goldfish/Makefile')
-rw-r--r--target/linux/goldfish/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/goldfish/Makefile b/target/linux/goldfish/Makefile
new file mode 100644
index 0000000000..08fdb6b579
--- /dev/null
+++ b/target/linux/goldfish/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=goldfish
+BOARDNAME:=Goldfish (Android Emulator)
+FEATURES:=
+CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -funit-at-a-time
+
+LINUX_VERSION:=2.6.30
+
+DEVICE_TYPE=phone
+
+define Target/Description
+ Android emulator virtual platform
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))