aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic
diff options
context:
space:
mode:
authorMagnus Kroken <mkroken@gmail.com>2018-03-03 01:12:07 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-03 12:58:55 +0100
commit5af85dab22a2ae78194d54d30c33fc2c1fb0f4e5 (patch)
tree66905f7c20499cbef087e0a3ce39676883381650 /target/linux/generic
parent45ae5c2de3491ed5db9695d21faebf95b3b41c56 (diff)
downloadupstream-5af85dab22a2ae78194d54d30c33fc2c1fb0f4e5.tar.gz
upstream-5af85dab22a2ae78194d54d30c33fc2c1fb0f4e5.tar.bz2
upstream-5af85dab22a2ae78194d54d30c33fc2c1fb0f4e5.zip
kernel: bump 4.9 to 4.9.85
Signed-off-by: Magnus Kroken <mkroken@gmail.com>
Diffstat (limited to 'target/linux/generic')
-rw-r--r--target/linux/generic/backport-4.9/011-kbuild-export-SUBARCH.patch2
-rw-r--r--target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch4
-rw-r--r--target/linux/generic/hack-4.9/202-reduce_module_size.patch2
-rw-r--r--target/linux/generic/hack-4.9/207-disable-modorder.patch4
-rw-r--r--target/linux/generic/hack-4.9/220-gc_sections.patch4
-rw-r--r--target/linux/generic/pending-4.9/201-extra_optimization.patch2
-rw-r--r--target/linux/generic/pending-4.9/812-pci-dwc-fix-enumeration.patch2
-rw-r--r--target/linux/generic/pending-4.9/890-uart_optional_sysrq.patch2
8 files changed, 10 insertions, 12 deletions
diff --git a/target/linux/generic/backport-4.9/011-kbuild-export-SUBARCH.patch b/target/linux/generic/backport-4.9/011-kbuild-export-SUBARCH.patch
index a191f9b2c6..d937c83f33 100644
--- a/target/linux/generic/backport-4.9/011-kbuild-export-SUBARCH.patch
+++ b/target/linux/generic/backport-4.9/011-kbuild-export-SUBARCH.patch
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -409,8 +409,8 @@ KERNELRELEASE = $(shell cat include/conf
+@@ -411,8 +411,8 @@ KERNELRELEASE = $(shell cat include/conf
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION
diff --git a/target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch b/target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
index d68670e219..4fe42a9c07 100644
--- a/target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
+++ b/target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
@@ -637,7 +637,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
return received;
--- a/drivers/net/ethernet/freescale/gianfar.c
+++ b/drivers/net/ethernet/freescale/gianfar.c
-@@ -3186,7 +3186,7 @@ static int gfar_poll_rx_sq(struct napi_s
+@@ -3193,7 +3193,7 @@ static int gfar_poll_rx_sq(struct napi_s
if (work_done < budget) {
u32 imask;
@@ -646,7 +646,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
/* Clear the halt bit in RSTAT */
gfar_write(&regs->rstat, gfargrp->rstat);
-@@ -3275,7 +3275,7 @@ static int gfar_poll_rx(struct napi_stru
+@@ -3282,7 +3282,7 @@ static int gfar_poll_rx(struct napi_stru
if (!num_act_queues) {
u32 imask;
diff --git a/target/linux/generic/hack-4.9/202-reduce_module_size.patch b/target/linux/generic/hack-4.9/202-reduce_module_size.patch
index 6e5fc9cd46..f744b945fe 100644
--- a/target/linux/generic/hack-4.9/202-reduce_module_size.patch
+++ b/target/linux/generic/hack-4.9/202-reduce_module_size.patch
@@ -13,7 +13,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -401,7 +401,7 @@ KBUILD_AFLAGS_KERNEL :=
+@@ -403,7 +403,7 @@ KBUILD_AFLAGS_KERNEL :=
KBUILD_CFLAGS_KERNEL :=
KBUILD_AFLAGS_MODULE := -DMODULE
KBUILD_CFLAGS_MODULE := -DMODULE
diff --git a/target/linux/generic/hack-4.9/207-disable-modorder.patch b/target/linux/generic/hack-4.9/207-disable-modorder.patch
index d52ca36c1c..da7ca2a15f 100644
--- a/target/linux/generic/hack-4.9/207-disable-modorder.patch
+++ b/target/linux/generic/hack-4.9/207-disable-modorder.patch
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -1200,7 +1200,6 @@ all: modules
+@@ -1202,7 +1202,6 @@ all: modules
PHONY += modules
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
@$(kecho) ' Building modules, stage 2.';
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
-@@ -1230,7 +1229,6 @@ _modinst_:
+@@ -1232,7 +1231,6 @@ _modinst_:
rm -f $(MODLIB)/build ; \
ln -s $(CURDIR) $(MODLIB)/build ; \
fi
diff --git a/target/linux/generic/hack-4.9/220-gc_sections.patch b/target/linux/generic/hack-4.9/220-gc_sections.patch
index e39f0f5f44..02e36b664e 100644
--- a/target/linux/generic/hack-4.9/220-gc_sections.patch
+++ b/target/linux/generic/hack-4.9/220-gc_sections.patch
@@ -21,7 +21,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
--- a/Makefile
+++ b/Makefile
-@@ -404,6 +404,11 @@ KBUILD_CFLAGS_MODULE := -DMODULE
+@@ -406,6 +406,11 @@ KBUILD_CFLAGS_MODULE := -DMODULE
KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
GCC_PLUGINS_CFLAGS :=
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -634,11 +639,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
+@@ -636,11 +641,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
KBUILD_CFLAGS += $(call cc-disable-warning, format-overflow)
KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)
diff --git a/target/linux/generic/pending-4.9/201-extra_optimization.patch b/target/linux/generic/pending-4.9/201-extra_optimization.patch
index 6a8467a8b2..2da816e4e0 100644
--- a/target/linux/generic/pending-4.9/201-extra_optimization.patch
+++ b/target/linux/generic/pending-4.9/201-extra_optimization.patch
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -640,12 +640,12 @@ KBUILD_CFLAGS += $(call cc-option,-fdata
+@@ -642,12 +642,12 @@ KBUILD_CFLAGS += $(call cc-option,-fdata
endif
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
diff --git a/target/linux/generic/pending-4.9/812-pci-dwc-fix-enumeration.patch b/target/linux/generic/pending-4.9/812-pci-dwc-fix-enumeration.patch
index 5092aba53f..bb0e0c4bb7 100644
--- a/target/linux/generic/pending-4.9/812-pci-dwc-fix-enumeration.patch
+++ b/target/linux/generic/pending-4.9/812-pci-dwc-fix-enumeration.patch
@@ -47,8 +47,6 @@ Will send separate patches to stable as this file got moved/renamed
drivers/pci/host/pcie-designware.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/drivers/pci/host/pcie-designware.c b/drivers/pci/host/pcie-designware.c
-index bf558df5b7b3..2b5470173196 100644
--- a/drivers/pci/host/pcie-designware.c
+++ b/drivers/pci/host/pcie-designware.c
@@ -861,7 +861,7 @@ void dw_pcie_setup_rc(struct pcie_port *
diff --git a/target/linux/generic/pending-4.9/890-uart_optional_sysrq.patch b/target/linux/generic/pending-4.9/890-uart_optional_sysrq.patch
index a69227b776..e3a1c8a7ee 100644
--- a/target/linux/generic/pending-4.9/890-uart_optional_sysrq.patch
+++ b/target/linux/generic/pending-4.9/890-uart_optional_sysrq.patch
@@ -26,7 +26,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
{
--- a/lib/Kconfig.debug
+++ b/lib/Kconfig.debug
-@@ -397,6 +397,11 @@ config MAGIC_SYSRQ_DEFAULT_ENABLE
+@@ -396,6 +396,11 @@ config MAGIC_SYSRQ_DEFAULT_ENABLE
This may be set to 1 or 0 to enable or disable them all, or
to a bitmask as described in Documentation/sysrq.txt.