aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic
diff options
context:
space:
mode:
authorStijn Segers <foss@volatilesystems.org>2018-03-22 18:34:08 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-23 23:49:55 +0100
commit41a881a8d9e7dc33b28768a8377ec67a7f8a0aae (patch)
treeb7c1d5a8a28186b8daee611a48ccc3675da1060c /target/linux/generic
parent4a788fcf63920769be3428d5c61eaa6f09d5291a (diff)
downloadupstream-41a881a8d9e7dc33b28768a8377ec67a7f8a0aae.tar.gz
upstream-41a881a8d9e7dc33b28768a8377ec67a7f8a0aae.tar.bz2
upstream-41a881a8d9e7dc33b28768a8377ec67a7f8a0aae.zip
Kernel: bump 4.14 to 4.14.29
Right patch version this time, sorry! * Patch 180-usb-xhci-add-support-for-performing-fake-doorbell.patch had to be adjusted slightly because of upstream adapted code. * Refreshed patches. Compile-tested: ramips/mt7621, x86/64 Run-tested: ramips/mt7621, x86/64 Signed-off-by: Stijn Segers <foss@volatilesystems.org> Tested-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'target/linux/generic')
-rw-r--r--target/linux/generic/backport-4.14/368-netfilter-nf_flow_table-fix-offloading-connections-w.patch2
-rw-r--r--target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch2
-rw-r--r--target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch2
-rw-r--r--target/linux/generic/hack-4.14/904-debloat_dma_buf.patch4
-rw-r--r--target/linux/generic/pending-4.14/180-net-phy-at803x-add-support-for-AT8032.patch8
-rw-r--r--target/linux/generic/pending-4.14/701-phy_extension.patch2
-rw-r--r--target/linux/generic/pending-4.14/734-net-phy-at803x-allow-to-configure-via-pdata.patch8
-rw-r--r--target/linux/generic/pending-4.14/735-net-phy-at803x-fix-at8033-sgmii-mode.patch2
8 files changed, 15 insertions, 15 deletions
diff --git a/target/linux/generic/backport-4.14/368-netfilter-nf_flow_table-fix-offloading-connections-w.patch b/target/linux/generic/backport-4.14/368-netfilter-nf_flow_table-fix-offloading-connections-w.patch
index 28c3817c70..f3d83a1536 100644
--- a/target/linux/generic/backport-4.14/368-netfilter-nf_flow_table-fix-offloading-connections-w.patch
+++ b/target/linux/generic/backport-4.14/368-netfilter-nf_flow_table-fix-offloading-connections-w.patch
@@ -12,7 +12,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/net/netfilter/nf_flow_table_core.c
+++ b/net/netfilter/nf_flow_table_core.c
-@@ -83,7 +83,7 @@ flow_offload_alloc(struct nf_conn *ct, s
+@@ -84,7 +84,7 @@ flow_offload_alloc(struct nf_conn *ct, s
if (ct->status & IPS_SRC_NAT)
flow->flags |= FLOW_OFFLOAD_SNAT;
diff --git a/target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch b/target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch
index 5b61d74672..7c724c0af7 100644
--- a/target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch
+++ b/target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
EXPORT_SYMBOL(default_qdisc_ops);
/* Main transmission queue. */
-@@ -764,7 +764,7 @@ static void attach_one_default_qdisc(str
+@@ -760,7 +760,7 @@ static void attach_one_default_qdisc(str
void *_unused)
{
struct Qdisc *qdisc;
diff --git a/target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch b/target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch
index 9c249ca4ce..61e460fda7 100644
--- a/target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch
+++ b/target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch
@@ -15,7 +15,7 @@
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
-@@ -1437,6 +1437,9 @@ int genphy_update_link(struct phy_device
+@@ -1451,6 +1451,9 @@ int genphy_update_link(struct phy_device
{
int status;
diff --git a/target/linux/generic/hack-4.14/904-debloat_dma_buf.patch b/target/linux/generic/hack-4.14/904-debloat_dma_buf.patch
index 44d10b0d52..e715909339 100644
--- a/target/linux/generic/hack-4.14/904-debloat_dma_buf.patch
+++ b/target/linux/generic/hack-4.14/904-debloat_dma_buf.patch
@@ -21,7 +21,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
+ tristate
default n
select ANON_INODES
- help
+ select IRQ_WORK
--- a/drivers/dma-buf/Makefile
+++ b/drivers/dma-buf/Makefile
@@ -1,3 +1,7 @@
@@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
+MODULE_LICENSE("GPL");
--- a/kernel/sched/core.c
+++ b/kernel/sched/core.c
-@@ -2146,6 +2146,7 @@ int wake_up_state(struct task_struct *p,
+@@ -2147,6 +2147,7 @@ int wake_up_state(struct task_struct *p,
{
return try_to_wake_up(p, state, 0);
}
diff --git a/target/linux/generic/pending-4.14/180-net-phy-at803x-add-support-for-AT8032.patch b/target/linux/generic/pending-4.14/180-net-phy-at803x-add-support-for-AT8032.patch
index 3b1a41a23b..86a03f2256 100644
--- a/target/linux/generic/pending-4.14/180-net-phy-at803x-add-support-for-AT8032.patch
+++ b/target/linux/generic/pending-4.14/180-net-phy-at803x-add-support-for-AT8032.patch
@@ -16,7 +16,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#define ATH8035_PHY_ID 0x004dd072
#define AT803X_PHY_ID_MASK 0xffffffef
-@@ -260,7 +261,8 @@ static int at803x_probe(struct phy_devic
+@@ -256,7 +257,8 @@ static int at803x_probe(struct phy_devic
if (!priv)
return -ENOMEM;
@@ -26,7 +26,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
goto does_not_require_reset_workaround;
gpiod_reset = devm_gpiod_get_optional(dev, "reset", GPIOD_OUT_LOW);
-@@ -336,7 +338,7 @@ static void at803x_link_change_notify(st
+@@ -332,7 +334,7 @@ static void at803x_link_change_notify(st
struct at803x_priv *priv = phydev->priv;
/*
@@ -35,7 +35,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
* signalled. This is necessary to circumvent a hardware bug that
* occurs when the cable is unplugged while TX packets are pending
* in the FIFO. In such cases, the FIFO enters an error mode it
-@@ -448,6 +450,24 @@ static struct phy_driver at803x_driver[]
+@@ -444,6 +446,24 @@ static struct phy_driver at803x_driver[]
.aneg_done = at803x_aneg_done,
.ack_interrupt = &at803x_ack_interrupt,
.config_intr = &at803x_config_intr,
@@ -60,7 +60,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
} };
module_phy_driver(at803x_driver);
-@@ -455,6 +475,7 @@ module_phy_driver(at803x_driver);
+@@ -451,6 +471,7 @@ module_phy_driver(at803x_driver);
static struct mdio_device_id __maybe_unused atheros_tbl[] = {
{ ATH8030_PHY_ID, AT803X_PHY_ID_MASK },
{ ATH8031_PHY_ID, AT803X_PHY_ID_MASK },
diff --git a/target/linux/generic/pending-4.14/701-phy_extension.patch b/target/linux/generic/pending-4.14/701-phy_extension.patch
index 1b380e24a9..2529505801 100644
--- a/target/linux/generic/pending-4.14/701-phy_extension.patch
+++ b/target/linux/generic/pending-4.14/701-phy_extension.patch
@@ -85,7 +85,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
* @phydev: the phy_device struct
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -905,6 +905,7 @@ void phy_ethtool_ksettings_get(struct ph
+@@ -906,6 +906,7 @@ void phy_ethtool_ksettings_get(struct ph
struct ethtool_link_ksettings *cmd);
int phy_ethtool_ksettings_set(struct phy_device *phydev,
const struct ethtool_link_ksettings *cmd);
diff --git a/target/linux/generic/pending-4.14/734-net-phy-at803x-allow-to-configure-via-pdata.patch b/target/linux/generic/pending-4.14/734-net-phy-at803x-allow-to-configure-via-pdata.patch
index 19dea170c3..a217f750bc 100644
--- a/target/linux/generic/pending-4.14/734-net-phy-at803x-allow-to-configure-via-pdata.patch
+++ b/target/linux/generic/pending-4.14/734-net-phy-at803x-allow-to-configure-via-pdata.patch
@@ -48,7 +48,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
};
struct at803x_context {
-@@ -277,8 +285,16 @@ does_not_require_reset_workaround:
+@@ -273,8 +281,16 @@ does_not_require_reset_workaround:
return 0;
}
@@ -65,7 +65,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
int ret;
ret = genphy_config_init(phydev);
-@@ -299,6 +315,26 @@ static int at803x_config_init(struct phy
+@@ -295,6 +311,26 @@ static int at803x_config_init(struct phy
return ret;
}
@@ -92,7 +92,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
return 0;
}
-@@ -336,6 +372,8 @@ static int at803x_config_intr(struct phy
+@@ -332,6 +368,8 @@ static int at803x_config_intr(struct phy
static void at803x_link_change_notify(struct phy_device *phydev)
{
struct at803x_priv *priv = phydev->priv;
@@ -101,7 +101,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
/*
* Conduct a hardware reset for AT8030/2 every time a link loss is
-@@ -364,6 +402,24 @@ static void at803x_link_change_notify(st
+@@ -360,6 +398,24 @@ static void at803x_link_change_notify(st
} else {
priv->phy_reset = false;
}
diff --git a/target/linux/generic/pending-4.14/735-net-phy-at803x-fix-at8033-sgmii-mode.patch b/target/linux/generic/pending-4.14/735-net-phy-at803x-fix-at8033-sgmii-mode.patch
index 3c686623b9..9a2f93a6f2 100644
--- a/target/linux/generic/pending-4.14/735-net-phy-at803x-fix-at8033-sgmii-mode.patch
+++ b/target/linux/generic/pending-4.14/735-net-phy-at803x-fix-at8033-sgmii-mode.patch
@@ -24,7 +24,7 @@ Signed-off-by: Roman Yeryomin <roman@advem.lv>
#define AT803X_MODE_CFG_MASK 0x0F
#define AT803X_MODE_CFG_SGMII 0x01
-@@ -296,6 +300,27 @@ static int at803x_config_init(struct phy
+@@ -292,6 +296,27 @@ static int at803x_config_init(struct phy
{
struct at803x_platform_data *pdata;
int ret;