aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic
diff options
context:
space:
mode:
authorJohn Audia <graysky@archlinux.us>2021-05-11 11:50:27 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-23 15:09:06 +0200
commit3e1c92f9e1be108df2042ab211cc8d68938e6af9 (patch)
tree4c584e34aca05f31dec4141b7d446dc283f9c36c /target/linux/generic
parentf726b37b681866145701bd1324c9c654312fa779 (diff)
downloadupstream-3e1c92f9e1be108df2042ab211cc8d68938e6af9.tar.gz
upstream-3e1c92f9e1be108df2042ab211cc8d68938e6af9.tar.bz2
upstream-3e1c92f9e1be108df2042ab211cc8d68938e6af9.zip
kernel: bump 5.4 to 5.4.118
Manually rebased: ath79/patches-5.4/0033-spi-ath79-drop-pdata-support.patch Removed uneeded patch: ath79/patches-5.4/0050-spi-ath79-remove-spi-master-setup-and-cleanup-assign.patch All other patches automatically rebased. Build system: x86_64 Build-tested: ipq806x/R7800 Run-tested: ipq806x/R7800 No dmesg regressions, everything functional Signed-off-by: John Audia <graysky@archlinux.us>
Diffstat (limited to 'target/linux/generic')
-rw-r--r--target/linux/generic/backport-5.4/080-wireguard-0052-crypto-x86-curve25519-support-assemblers-with-no-adx.patch2
-rw-r--r--target/linux/generic/hack-5.4/204-module_strip.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic/backport-5.4/080-wireguard-0052-crypto-x86-curve25519-support-assemblers-with-no-adx.patch b/target/linux/generic/backport-5.4/080-wireguard-0052-crypto-x86-curve25519-support-assemblers-with-no-adx.patch
index 513025552d..cd507b1e44 100644
--- a/target/linux/generic/backport-5.4/080-wireguard-0052-crypto-x86-curve25519-support-assemblers-with-no-adx.patch
+++ b/target/linux/generic/backport-5.4/080-wireguard-0052-crypto-x86-curve25519-support-assemblers-with-no-adx.patch
@@ -24,7 +24,7 @@ Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
--- a/arch/x86/Makefile
+++ b/arch/x86/Makefile
-@@ -197,9 +197,10 @@ avx2_instr :=$(call as-instr,vpbroadcast
+@@ -198,9 +198,10 @@ avx2_instr :=$(call as-instr,vpbroadcast
avx512_instr :=$(call as-instr,vpmovm2b %k1$(comma)%zmm5,-DCONFIG_AS_AVX512=1)
sha1_ni_instr :=$(call as-instr,sha1msg1 %xmm0$(comma)%xmm1,-DCONFIG_AS_SHA1_NI=1)
sha256_ni_instr :=$(call as-instr,sha256msg1 %xmm0$(comma)%xmm1,-DCONFIG_AS_SHA256_NI=1)
diff --git a/target/linux/generic/hack-5.4/204-module_strip.patch b/target/linux/generic/hack-5.4/204-module_strip.patch
index a207a11ee5..22bb1ac33a 100644
--- a/target/linux/generic/hack-5.4/204-module_strip.patch
+++ b/target/linux/generic/hack-5.4/204-module_strip.patch
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
config MODULES_TREE_LOOKUP
--- a/kernel/module.c
+++ b/kernel/module.c
-@@ -3224,9 +3224,11 @@ static int setup_load_info(struct load_i
+@@ -3252,9 +3252,11 @@ static int setup_load_info(struct load_i
static int check_modinfo(struct module *mod, struct load_info *info, int flags)
{
@@ -125,7 +125,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (flags & MODULE_INIT_IGNORE_VERMAGIC)
modmagic = NULL;
-@@ -3247,6 +3249,7 @@ static int check_modinfo(struct module *
+@@ -3275,6 +3277,7 @@ static int check_modinfo(struct module *
mod->name);
add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
}