aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/pending-4.19
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2020-03-24 11:19:41 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-05-08 15:17:17 +0200
commit2976e423dc6e8dd08e39569a57d75330abf6df14 (patch)
tree7f3c3cd61b10475c2d40bfc3c2dfa14260fecd75 /target/linux/generic/pending-4.19
parentee5ee99dcfb87a48a9f5d63e0ad597a7e0062c11 (diff)
downloadupstream-2976e423dc6e8dd08e39569a57d75330abf6df14.tar.gz
upstream-2976e423dc6e8dd08e39569a57d75330abf6df14.tar.bz2
upstream-2976e423dc6e8dd08e39569a57d75330abf6df14.zip
generic: routerboot partition build bits
Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
Diffstat (limited to 'target/linux/generic/pending-4.19')
-rw-r--r--target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch b/target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch
new file mode 100644
index 0000000000..678eaed4ce
--- /dev/null
+++ b/target/linux/generic/pending-4.19/435-mtd-add-routerbootpart-parser-config.patch
@@ -0,0 +1,41 @@
+From 4437e01fb6bca63fccdba5d6c44888b0935885c2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thibaut=20VAR=C3=88NE?= <hacks@slashdirt.org>
+Date: Tue, 24 Mar 2020 11:45:07 +0100
+Subject: [PATCH] generic: routerboot partition build bits (4.19)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This patch adds routerbootpart kernel build bits
+
+Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
+---
+ drivers/mtd/parsers/Kconfig | 9 +++++++++
+ drivers/mtd/parsers/Makefile | 1 +
+ 2 files changed, 10 insertions(+)
+
+diff --git a/drivers/mtd/parsers/Kconfig b/drivers/mtd/parsers/Kconfig
+index de6f5f8..0afa89c 100644
+--- a/drivers/mtd/parsers/Kconfig
++++ b/drivers/mtd/parsers/Kconfig
+@@ -22,3 +22,12 @@ config MTD_SHARPSL_PARTS
+ This provides the read-only FTL logic necessary to read the partition
+ table from the NAND flash of Sharp SL Series (Zaurus) and the MTD
+ partition parser using this code.
++
++config MTD_ROUTERBOOT_PARTS
++ tristate "RouterBoot flash partition parser"
++ depends on MTD && OF
++ help
++ MikroTik RouterBoot is implemented as a multi segment system on the
++ flash, some of which are fixed and some of which are located at
++ variable offsets. This parser handles both cases via properly
++ formatted DTS.
+diff --git a/drivers/mtd/parsers/Makefile b/drivers/mtd/parsers/Makefile
+index 44ff342..0543362 100644
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -1,2 +1,3 @@
+ obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
+ obj-$(CONFIG_MTD_SHARPSL_PARTS) += sharpslpart.o
++obj-$(CONFIG_MTD_ROUTERBOOT_PARTS) += routerbootpart.o