aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.9/308-mips32r2_tune.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-27 14:32:10 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-04 20:28:14 +0100
commitf791fb4af45032a653ba7c850f4564923871cb16 (patch)
treec1fc4e564c8e27faad582e5b55a9ce91816a241c /target/linux/generic/patches-4.9/308-mips32r2_tune.patch
parent7d00cfe9bb693e376ac9d035e13f8ce8a5ff572c (diff)
downloadupstream-f791fb4af45032a653ba7c850f4564923871cb16.tar.gz
upstream-f791fb4af45032a653ba7c850f4564923871cb16.tar.bz2
upstream-f791fb4af45032a653ba7c850f4564923871cb16.zip
kernel: add linux 4.9 support
Signed-off-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Tim Harvey <tharvey@gateworks.com> [fixes]
Diffstat (limited to 'target/linux/generic/patches-4.9/308-mips32r2_tune.patch')
-rw-r--r--target/linux/generic/patches-4.9/308-mips32r2_tune.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.9/308-mips32r2_tune.patch b/target/linux/generic/patches-4.9/308-mips32r2_tune.patch
new file mode 100644
index 0000000000..f2dbdac911
--- /dev/null
+++ b/target/linux/generic/patches-4.9/308-mips32r2_tune.patch
@@ -0,0 +1,17 @@
+Add -mtune=34kc to MIPS CFLAGS when building for mips32r2
+This provides a good tradeoff across at least 24Kc-74Kc, while also
+producing smaller code.
+
+Signed-off-by: Felix Fietkau <nbd@nbd.name>
+
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -148,7 +148,7 @@ cflags-$(CONFIG_CPU_R4X00) += -march=r46
+ cflags-$(CONFIG_CPU_TX49XX) += -march=r4600 -Wa,--trap
+ cflags-$(CONFIG_CPU_MIPS32_R1) += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
+ -Wa,-mips32 -Wa,--trap
+-cflags-$(CONFIG_CPU_MIPS32_R2) += $(call cc-option,-march=mips32r2,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
++cflags-$(CONFIG_CPU_MIPS32_R2) += $(call cc-option,-march=mips32r2 -mtune=34kc,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
+ -Wa,-mips32r2 -Wa,--trap
+ cflags-$(CONFIG_CPU_MIPS32_R6) += -march=mips32r6 -Wa,--trap
+ cflags-$(CONFIG_CPU_MIPS64_R1) += $(call cc-option,-march=mips64,-mips64 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS64) \