aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-04-12 09:35:14 +0200
committerJo-Philipp Wich <jo@mein.io>2017-12-13 12:57:41 +0100
commit157b892994726ca580a1326f34feabf7f627c94d (patch)
tree5c02020815f29ff82e7d6f8d5e5a9388fb803103 /target/linux/generic/patches-4.4
parentadc9f935c34d42375f0ea5d29a8995a99f75466f (diff)
downloadupstream-157b892994726ca580a1326f34feabf7f627c94d.tar.gz
upstream-157b892994726ca580a1326f34feabf7f627c94d.tar.bz2
upstream-157b892994726ca580a1326f34feabf7f627c94d.zip
kernel: remove out of tree direct-io disable hack
Direct-IO support has to be enabled for the release build anyway, so this hack is not worth keeping Signed-off-by: Felix Fietkau <nbd@nbd.name> (backported from commit 0b7ed65cec8084bb98ae0e2758b7aca6c447cd4b) Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/generic/patches-4.4')
-rw-r--r--target/linux/generic/patches-4.4/903-debloat_direct_io.patch80
1 files changed, 0 insertions, 80 deletions
diff --git a/target/linux/generic/patches-4.4/903-debloat_direct_io.patch b/target/linux/generic/patches-4.4/903-debloat_direct_io.patch
deleted file mode 100644
index 82e6a6b1cf..0000000000
--- a/target/linux/generic/patches-4.4/903-debloat_direct_io.patch
+++ /dev/null
@@ -1,80 +0,0 @@
---- a/fs/Kconfig
-+++ b/fs/Kconfig
-@@ -74,6 +74,11 @@ config FILE_LOCKING
- for filesystems like NFS and for the flock() system
- call. Disabling this option saves about 11k.
-
-+config DIRECT_IO
-+ bool "Enable O_DIRECT support" if EXPERT
-+ depends on BLOCK
-+ default y
-+
- source "fs/notify/Kconfig"
-
- source "fs/quota/Kconfig"
---- a/fs/Makefile
-+++ b/fs/Makefile
-@@ -14,7 +14,8 @@ obj-y := open.o read_write.o file_table.
- stack.o fs_struct.o statfs.o fs_pin.o nsfs.o
-
- ifeq ($(CONFIG_BLOCK),y)
--obj-y += buffer.o block_dev.o direct-io.o mpage.o
-+obj-y += buffer.o block_dev.o mpage.o
-+obj-$(CONFIG_DIRECT_IO) += direct-io.o
- else
- obj-y += no-block.o
- endif
---- a/include/linux/fs.h
-+++ b/include/linux/fs.h
-@@ -2722,6 +2722,7 @@ enum {
- DIO_SKIP_DIO_COUNT = 0x08,
- };
-
-+#ifdef CONFIG_DIRECT_IO
- void dio_end_io(struct bio *bio, int error);
-
- ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
-@@ -2729,6 +2730,18 @@ ssize_t __blockdev_direct_IO(struct kioc
- loff_t offset, get_block_t get_block,
- dio_iodone_t end_io, dio_submit_t submit_io,
- int flags);
-+#else
-+static inline void dio_end_io(struct bio *bio, int error)
-+{
-+}
-+static inline ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
-+ struct block_device *bdev, struct iov_iter *iter, loff_t offset,
-+ get_block_t get_block, dio_iodone_t end_io,
-+ dio_submit_t submit_io, int flags)
-+{
-+ return -EOPNOTSUPP;
-+}
-+#endif
-
- static inline ssize_t blockdev_direct_IO(struct kiocb *iocb,
- struct inode *inode,
---- a/fs/fcntl.c
-+++ b/fs/fcntl.c
-@@ -52,8 +52,10 @@ static int setfl(int fd, struct file * f
- arg |= O_NONBLOCK;
-
- if (arg & O_DIRECT) {
-+#ifdef CONFIG_DIRECT_IO
- if (!filp->f_mapping || !filp->f_mapping->a_ops ||
- !filp->f_mapping->a_ops->direct_IO)
-+#endif
- return -EINVAL;
- }
-
---- a/fs/open.c
-+++ b/fs/open.c
-@@ -673,7 +673,9 @@ int open_check_o_direct(struct file *f)
- {
- /* NB: we're sure to have correct a_ops only after f_op->open */
- if (f->f_flags & O_DIRECT) {
-+#ifdef CONFIG_DIRECT_IO
- if (!f->f_mapping->a_ops || !f->f_mapping->a_ops->direct_IO)
-+#endif
- return -EINVAL;
- }
- return 0;