aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/726-phy_rtl8366.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-03-07 17:56:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-03-07 17:56:58 +0000
commit46c7d0d1ab610701b91ac9ba465e63f51e80ee06 (patch)
treeac61f4ccb56d99a7cf65fc19840cc4c906ce65f3 /target/linux/generic/patches-4.3/726-phy_rtl8366.patch
parent3abf5ce6564e24a388b86caf1a00f91f4262b312 (diff)
downloadupstream-46c7d0d1ab610701b91ac9ba465e63f51e80ee06.tar.gz
upstream-46c7d0d1ab610701b91ac9ba465e63f51e80ee06.tar.bz2
upstream-46c7d0d1ab610701b91ac9ba465e63f51e80ee06.zip
kernel: remove linux 4.3 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48955
Diffstat (limited to 'target/linux/generic/patches-4.3/726-phy_rtl8366.patch')
-rw-r--r--target/linux/generic/patches-4.3/726-phy_rtl8366.patch46
1 files changed, 0 insertions, 46 deletions
diff --git a/target/linux/generic/patches-4.3/726-phy_rtl8366.patch b/target/linux/generic/patches-4.3/726-phy_rtl8366.patch
deleted file mode 100644
index 2547f66b89..0000000000
--- a/target/linux/generic/patches-4.3/726-phy_rtl8366.patch
+++ /dev/null
@@ -1,46 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -266,6 +266,31 @@ config MDIO_BCM_UNIMAC
- This hardware can be found in the Broadcom GENET Ethernet MAC
- controllers as well as some Broadcom Ethernet switches such as the
- Starfighter 2 switches.
-+
-+config RTL8366_SMI
-+ tristate "Driver for the RTL8366 SMI interface"
-+ depends on GPIOLIB
-+ ---help---
-+ This module implements the SMI interface protocol which is used
-+ by some RTL8366 ethernet switch devices via the generic GPIO API.
-+
-+if RTL8366_SMI
-+
-+config RTL8366_SMI_DEBUG_FS
-+ bool "RTL8366 SMI interface debugfs support"
-+ depends on DEBUG_FS
-+ default n
-+
-+config RTL8366S_PHY
-+ tristate "Driver for the Realtek RTL8366S switch"
-+ select SWCONFIG
-+
-+config RTL8366RB_PHY
-+ tristate "Driver for the Realtek RTL8366RB switch"
-+ select SWCONFIG
-+
-+endif # RTL8366_SMI
-+
- endif # PHYLIB
-
- config MICREL_KS8995MA
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -26,6 +26,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
- obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
- obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
-+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
-+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
-+obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o