aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.1/201-extra_optimization.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-06-22 12:27:59 +0000
committerJonas Gorski <jogo@openwrt.org>2015-06-22 12:27:59 +0000
commita0c49ef46f7caf5eb02c635d446218201008ecff (patch)
treea94180d50839c1587dfe845e8faf16405fab78ff /target/linux/generic/patches-4.1/201-extra_optimization.patch
parent518ab154e059c9f39684f8c78159c9caf333716b (diff)
downloadupstream-a0c49ef46f7caf5eb02c635d446218201008ecff.tar.gz
upstream-a0c49ef46f7caf5eb02c635d446218201008ecff.tar.bz2
upstream-a0c49ef46f7caf5eb02c635d446218201008ecff.zip
generic: add linux 4.1 support
Boot tested: http://pastebin.com/L6aAb9xj Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: update to 4.1 final add patches added since submission delete patches applied in later rcs restore commit messages in 220-gc-sections and 304-mips_disable_fpu fix 050-backport_netfilter_rtcache to match new API update inlined dma ops with upstream changes add missing config symbols enabled CONFIG_MULTIUSER update kmod defintions for 4.1 ] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46112
Diffstat (limited to 'target/linux/generic/patches-4.1/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-4.1/201-extra_optimization.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.1/201-extra_optimization.patch b/target/linux/generic/patches-4.1/201-extra_optimization.patch
new file mode 100644
index 0000000000..34ded8c7eb
--- /dev/null
+++ b/target/linux/generic/patches-4.1/201-extra_optimization.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -612,9 +612,9 @@ include arch/$(SRCARCH)/Makefile
+ KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks,)
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
++KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION) $(call cc-disable-warning,maybe-uninitialized,)
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
+ endif
+
+ # Tell gcc to never replace conditional load with a non-conditional one