aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.0/733-phy_mvsw61xx.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-02-23 22:59:53 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-02-23 22:59:53 +0000
commit1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f (patch)
tree0a83cfa5ea98e519ade4fa7f4e8a859e26bd737c /target/linux/generic/patches-4.0/733-phy_mvsw61xx.patch
parentad077832bfb03106a02b7be02b560c13e77d0436 (diff)
downloadupstream-1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f.tar.gz
upstream-1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f.tar.bz2
upstream-1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f.zip
generic: early (incomplete!) 4.0 support
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 44511
Diffstat (limited to 'target/linux/generic/patches-4.0/733-phy_mvsw61xx.patch')
-rw-r--r--target/linux/generic/patches-4.0/733-phy_mvsw61xx.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.0/733-phy_mvsw61xx.patch b/target/linux/generic/patches-4.0/733-phy_mvsw61xx.patch
new file mode 100644
index 0000000000..041d168b65
--- /dev/null
+++ b/target/linux/generic/patches-4.0/733-phy_mvsw61xx.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -143,6 +143,10 @@ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+ select ETHERNET_PACKET_MANGLE
+
++config MVSW61XX_PHY
++ tristate "Driver for Marvell 88E6171/6172 switches"
++ select SWCONFIG
++
+ config IP17XX_PHY
+ tristate "Driver for IC+ IP17xx switches"
+ select SWCONFIG
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,7 @@ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_MVSW61XX_PHY) += mvsw61xx.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o