aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.8/724-phy_ar8216.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-08 22:19:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-08 22:19:31 +0000
commit8dbed04ec9cad7771590af557b9edfe8e04bca8c (patch)
tree412beb5055a726a8f371c35580bdc85300e4e2f7 /target/linux/generic/patches-3.8/724-phy_ar8216.patch
parentc38cb63808ff1a395dd0384af23773b044adf9cb (diff)
downloadupstream-8dbed04ec9cad7771590af557b9edfe8e04bca8c.tar.gz
upstream-8dbed04ec9cad7771590af557b9edfe8e04bca8c.tar.bz2
upstream-8dbed04ec9cad7771590af557b9edfe8e04bca8c.zip
kernel: add support for 3.8-rc2
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35055
Diffstat (limited to 'target/linux/generic/patches-3.8/724-phy_ar8216.patch')
-rw-r--r--target/linux/generic/patches-3.8/724-phy_ar8216.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.8/724-phy_ar8216.patch b/target/linux/generic/patches-3.8/724-phy_ar8216.patch
new file mode 100644
index 0000000000..d196032bc1
--- /dev/null
+++ b/target/linux/generic/patches-3.8/724-phy_ar8216.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -136,6 +136,11 @@ config IP17XX_PHY
+ tristate "Driver for IC+ IP17xx switches"
+ select SWCONFIG
+
++config AR8216_PHY
++ tristate "Driver for Atheros AR8216 switches"
++ select ETHERNET_PACKET_MANGLE
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -21,6 +21,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
++obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o