aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.7/500-yaffs-Kbuild-integration.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
commit935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0 (patch)
tree48e34d859046c692a221dddd165db5abc37feb90 /target/linux/generic/patches-3.7/500-yaffs-Kbuild-integration.patch
parentd0226aff1d62d39530819938ac116ee3cbb93efa (diff)
downloadupstream-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.tar.gz
upstream-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.tar.bz2
upstream-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.zip
add 3.7-rc6 support (patch 820 still has to be fixed)
SVN-Revision: 34247
Diffstat (limited to 'target/linux/generic/patches-3.7/500-yaffs-Kbuild-integration.patch')
-rw-r--r--target/linux/generic/patches-3.7/500-yaffs-Kbuild-integration.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.7/500-yaffs-Kbuild-integration.patch b/target/linux/generic/patches-3.7/500-yaffs-Kbuild-integration.patch
new file mode 100644
index 0000000000..9c7f895fdc
--- /dev/null
+++ b/target/linux/generic/patches-3.7/500-yaffs-Kbuild-integration.patch
@@ -0,0 +1,18 @@
+--- a/fs/Kconfig
++++ b/fs/Kconfig
+@@ -39,6 +39,7 @@ source "fs/gfs2/Kconfig"
+ source "fs/ocfs2/Kconfig"
+ source "fs/btrfs/Kconfig"
+ source "fs/nilfs2/Kconfig"
++source "fs/yaffs2/Kconfig"
+
+ endif # BLOCK
+
+--- a/fs/Makefile
++++ b/fs/Makefile
+@@ -127,3 +127,5 @@ obj-$(CONFIG_GFS2_FS) += gfs2/
+ obj-y += exofs/ # Multiple modules
+ obj-$(CONFIG_CEPH_FS) += ceph/
+ obj-$(CONFIG_PSTORE) += pstore/
++obj-$(CONFIG_YAFFS_FS) += yaffs2/
++