aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.7/201-extra_optimization.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
commit935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0 (patch)
tree48e34d859046c692a221dddd165db5abc37feb90 /target/linux/generic/patches-3.7/201-extra_optimization.patch
parentd0226aff1d62d39530819938ac116ee3cbb93efa (diff)
downloadupstream-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.tar.gz
upstream-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.tar.bz2
upstream-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.zip
add 3.7-rc6 support (patch 820 still has to be fixed)
SVN-Revision: 34247
Diffstat (limited to 'target/linux/generic/patches-3.7/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.7/201-extra_optimization.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.7/201-extra_optimization.patch b/target/linux/generic/patches-3.7/201-extra_optimization.patch
new file mode 100644
index 0000000000..d94d2cf3a8
--- /dev/null
+++ b/target/linux/generic/patches-3.7/201-extra_optimization.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -570,9 +570,9 @@ endif # $(dot-config)
+ all: vmlinux
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os
++KBUILD_CFLAGS += -Os -fno-caller-saves
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -645,6 +645,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+