aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-29 09:38:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-29 09:38:21 +0000
commit41e6994664a5f304b5d0b1517fefd8c3950288ff (patch)
tree3c144ab83f9e1600d098ebf2bf9bf0919e2eaa73 /target/linux/generic/patches-3.3
parent01c8aa3d2018c78d9f6883bee5bbaae4aa158e1f (diff)
downloadupstream-41e6994664a5f304b5d0b1517fefd8c3950288ff.tar.gz
upstream-41e6994664a5f304b5d0b1517fefd8c3950288ff.tar.bz2
upstream-41e6994664a5f304b5d0b1517fefd8c3950288ff.zip
kernel: stop patching -funit-at-a-time into CFLAGS, it has no effect on recent compilers
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37598 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.3')
-rw-r--r--target/linux/generic/patches-3.3/201-extra_optimization.patch10
1 files changed, 0 insertions, 10 deletions
diff --git a/target/linux/generic/patches-3.3/201-extra_optimization.patch b/target/linux/generic/patches-3.3/201-extra_optimization.patch
index 6fe8b0938d..e724891e4f 100644
--- a/target/linux/generic/patches-3.3/201-extra_optimization.patch
+++ b/target/linux/generic/patches-3.3/201-extra_optimization.patch
@@ -12,13 +12,3 @@
endif
include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -620,6 +620,9 @@ endif
- NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
- CHECKFLAGS += $(NOSTDINC_FLAGS)
-
-+# improve gcc optimization
-+CFLAGS += $(call cc-option,-funit-at-a-time,)
-+
- # warn about C99 declaration after statement
- KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
-