aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3/729-phy-rtl8367b.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-10-18 07:22:56 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-10-18 07:22:56 +0000
commit0045449b1bfcb64ed4eb3e7ea25e62aa0491b404 (patch)
tree1c3fc351f5e4b297e2b50fbdd360be252a588037 /target/linux/generic/patches-3.3/729-phy-rtl8367b.patch
parente36eb8579f6d608210b2e8007b00baace97b4de4 (diff)
downloadupstream-0045449b1bfcb64ed4eb3e7ea25e62aa0491b404.tar.gz
upstream-0045449b1bfcb64ed4eb3e7ea25e62aa0491b404.tar.bz2
upstream-0045449b1bfcb64ed4eb3e7ea25e62aa0491b404.zip
generic: add driver for the the RTL8367R{B,-VB} switches
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 33839
Diffstat (limited to 'target/linux/generic/patches-3.3/729-phy-rtl8367b.patch')
-rw-r--r--target/linux/generic/patches-3.3/729-phy-rtl8367b.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.3/729-phy-rtl8367b.patch b/target/linux/generic/patches-3.3/729-phy-rtl8367b.patch
new file mode 100644
index 0000000000..82a7386f96
--- /dev/null
+++ b/target/linux/generic/patches-3.3/729-phy-rtl8367b.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -199,6 +199,10 @@ config RTL8367_PHY
+ tristate "Driver for the Realtek RTL8367R/M switches"
+ select SWCONFIG
+
++config RTL8367B_PHY
++ tristate "Driver fot the Realtek RTL8367R-VB switch"
++ select SWCONFIG
++
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -26,6 +26,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
++obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o