aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.1
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-07 19:36:31 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-07 19:36:31 +0000
commit8b567fb508573e35f1acfce638cdc76617c1f0b8 (patch)
treea0bb7f04cc1cbff1207dbac360beb49fff9acd75 /target/linux/generic/patches-3.1
parent87fb92ee03d6d3ceaa403d057a068001d8fecc1d (diff)
downloadupstream-8b567fb508573e35f1acfce638cdc76617c1f0b8.tar.gz
upstream-8b567fb508573e35f1acfce638cdc76617c1f0b8.tar.bz2
upstream-8b567fb508573e35f1acfce638cdc76617c1f0b8.zip
generic: add driver for the RTL8367R/M switches
SVN-Revision: 29678
Diffstat (limited to 'target/linux/generic/patches-3.1')
-rw-r--r--target/linux/generic/patches-3.1/727-phy-rtl8367.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.1/727-phy-rtl8367.patch b/target/linux/generic/patches-3.1/727-phy-rtl8367.patch
new file mode 100644
index 0000000000..820bda0cdb
--- /dev/null
+++ b/target/linux/generic/patches-3.1/727-phy-rtl8367.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -179,6 +179,10 @@ config RTL8366RB_PHY
+ tristate "Driver for the Realtek RTL8366RB switch"
+ select SWCONFIG
+
++config RTL8367_PHY
++ tristate "Driver for the Realtek RTL8367R/M switches"
++ select SWCONFIG
++
+ config RTL8366S_PHY_DEBUG_FS
+ bool "RTL8366 switch driver DEBUG_FS support"
+ depends on RTL8366S_PHY || RTL8366RB_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -23,6 +23,7 @@ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
++obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o