aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.19/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
commitd26694243af236fed09a4b38f3cc68e40ad063b5 (patch)
treedf356ae59718ae0996986ccb61155243098dbc3f /target/linux/generic/patches-3.19/940-ocf_kbuild_integration.patch
parenta46bb6ec6a0ed6eb56dc2f4551a57e63a7292753 (diff)
downloadupstream-d26694243af236fed09a4b38f3cc68e40ad063b5.tar.gz
upstream-d26694243af236fed09a4b38f3cc68e40ad063b5.tar.bz2
upstream-d26694243af236fed09a4b38f3cc68e40ad063b5.zip
generic: add preliminary 3.19 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44126
Diffstat (limited to 'target/linux/generic/patches-3.19/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-3.19/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.19/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-3.19/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..240f15eb61
--- /dev/null
+++ b/target/linux/generic/patches-3.19/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1519,3 +1519,6 @@ source "drivers/crypto/Kconfig"
+ source crypto/asymmetric_keys/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -101,6 +101,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #